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Welcome to Internet Space Builder

What is ISB

ParallelGraphics Internet Space Builder (ISB) lets you easily create 3D worlds and publish them on the
World Wide Web. Anyone can visit and experience your 3D Web site using standard VRML2.0
browsers. ISB adds a new dimension of reality to your Web sites with a complete library of editable 3D
shapes. Combined with interactive texture mapping ISB brings your 3D space to life.

ISB Features

ISB includes features that help you work conveniently and quickly. These features include:

Creating and editing true 3D scenes and objects using 3D Boolean operations (adding and
subtracting) over a broader range of 3D primitives such as spheres, pyramids, cones and
cylinders.

VRML 2.0 compliance: you can import and export scenes and objects in VRML 2.0 format as well
as view created scenes in all major VRML browsers, such as Intervista World View, Cosmo
Player, and others.

Utilizing rich galleries with standard shapes, textures, pictures, objects and movies.
Importing 3DS objects (3D Studio), DXF files (AutoCAD), MUS (VHSB), and D96 files.
Exporting in AutoCAD DXF format.

Creating additional viewpoints (cameras) with possibility to select a camera from the list.
Visual support for a user-defined object hierarchy on the Scene Tree.

Advanced interactive texture mapping and editing, setting material transparency and color and the
ability to draw directly on textures with immediate display of all changes in the 3D space.

Creating and formatting 3D fonts.

One-button posting of VRML scenes to the Web.

Customizable user interface with multiple layouts.

Support for the VRML geometry nodes Box, Cone, Cylinder, Sphere, Text

Using 8-bit (256 color mode), 16-bit (high color mode), 24-bit (true color mode) and 32-bit (true
color mode with advanced lighting) rendering modes. Support for Intel's MMX® instruction set.

Capability of creating a shape using a smooth curve (Spline Mode).

Optimization of VRML output.

Capability of choosing the scene landscape from a set of pre-defined landscapes.
Customizable keyboard navigation commands for the camera.

Change, rename, and format conversion operations for the resource files, referenced in the scene
file.

Editing operations directly in the Perspective View window.
Importing and exporting worlds in compressed VRML 2.0 format (gzip).

ISB Quick Start Guide

An HTML document that provides tutorials on the features of ISB and reference information. It is shown
when you start ISB for the first time and also available from the start menu in the default Internet
browser or at the Tutorials tab of the Switch bar.
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Getting Help

Getting assistance

You can get help without interrupting your work. For an explanation of any item such as a menu
command, a toolbar button, a dialog box, or a screen item:

. El Click the Help button on the Standard toolbar, and then click the item. Or
* Position the pointer over the menu item and press F1.

For a brief description of a menu command:
* Position the pointer over the command. The description will appear on the Status bar.

For a description of a toolbar button:
* Position the pointer over the button. The name will appear below the button.

Hardware and system requirements

e Operating system: Microsoft® Windows® 95/98 or Windows NT® 4.0.
e Computer: 486 or better, Pentium® is recommended.
¢ Random Access Memory (RAM): minimum of 8 MB.

* Free disk space: 12 MB of hard disk space for program files, recommended free space for swap
file growing - 40 MB.

* Display: SVGA/256 colors. The 800x600, high color mode is recommended.
* Interface: Mouse and keyboard, optional pen.

* CD-ROM drive: optional.

e Sound card: optional.

Installation

ISB is available in two types of installation packaging: either as a downloadable package (electronic
online distribution) or on CD ROM. The Setup program provided with each package creates all the
necessary folders on your hard disk and installs all necessary software components along with content
libraries. To install ISB:

1 Start Windows.
2 Run setup.exe program from the ISB installation package. An ISB Setup splash screen appears.
3 Follow setup.exe instructions.

The Setup program automatically creates ISB program group.

* Double-click the ReadMe icon for up-to-the-moment product news.

* To start the program click the Start button, point to Programs, point to Internet Space Builder, and
then click Internet Space Builder.

Note:

You may read the ISB Quick Start Guide document by clicking Quick Start Guide.
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Uninstalling 1SB

To remove the ISB program:

1 Click the Start button and then point to Settings.
2 Click Control Panel, and then Double-click the Add/Remove Programs icon .
3 In the dialog box select Internet Space Builder 3.0 and click the Add/Remove button.

4 Click Yes if you want to remove the ISB installation completely. Click No if you decided to keep
ISB.

Notes:

* The UninstallShield program deletes all the standard ISB components, standard gallery files and
registry entries. You must manually remove any shortcuts to ISB you have created elsewhere.

* The UninstallShield program does not delete the elements which you created by yourself in any
gallery. The corresponding gallery folders are also not deleted. You may use them later with the
newly installed ISB.

Technical support

We are interested in receiving your comments and suggestions about ISB. For product support, send e-
mail to support@parallelgraphics.com. Before posting your message, please follow these simple
instructions:

1 Check the Quick Start Guide and online Help.

2 In your message include any information that could help answer your question or solve the
problem.

3 Document the system configuration: OS version, CPU type, memory, sound card, graphics card,
monitor, etc.

4 When error messages occurs please document the complete message including sub dialog details
and provide step-by-step instructions for reproducing the problem.

ParallelGraphics Web Site

Visit http://www.parallelgraphics.com on the World Wide Web for the latest information on our company,
future product releases, and as a central location for visiting other ISB 3D spaces.

Frequently asked questions

e | cannot save in .MUS or VRML 1.0 formats.
ISB allows you to save the created scene both in the VRML 2.0 and .dxf (AutoCAD) format. The
MUS format (the Virtual Home Space Builder format) is supported for reading only. That is to say,
if you have a scene in VHSB, you can view and edit it in ISB, but cannot save it as a .MUS file
again.

* Can ISB read a VRML 2.0 file prepared in any other editor?
Yes, ISB can read VRML 2.0 files prepared in other editors. If the file contains any sentence not
implemented in ISB that sentence is ignored with warning “VRML file contained some information,
which ISB cannot save in the original form. To prevent loss of data save to different name.

* May | create my own objects?
Yes, you may create your own objects using ISB and save them in the Object Gallery, or import
the objects from the 3D Studio file format.

e Can | walk through the walls in ISB?
To walk through the walls in the Perspective View window release the Collider button on the
Camera toolbar. You can freely navigate a camera through the walls in the Plan window.

* Can I place links to HTML pages or other VRML worlds?
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Yes, the HTML links can be attached to pictures, movies and other scene objects. To link a URL,
right-click the object you wish to link in the Scene Tree window, a pop-up menu appears which
contains the Link URL option.

* | couldn't find an option to get the split modeling screen for top and side viewpoints. Is there an
option somewhere that | don't know of?
To simulate a side-view, you can use the Plan wheel located on the bottom of the Plan window.
For example, to get the plan left view, rotate the Plan wheel to the right until its next black mark fit
the red triangle. You can rotate the Plan wheel with the mouse.

e Can | make the shape rotation smooth?
Yes, to do this, rotate the shape while holding down the Ctrl key.
e Can |l increase or decrease a shape in two directions simultaneously?
Yes, to do this, increase or decrease the shape while holding down the Shift key.

e Can |l increase or decrease a shape in all directions keeping its proportions?
Yes, to do this, press Gray + key on the numeric keypad to increase the shape or press Gray - key
to reduce the shape.

e Can | texture a whole object?
Yes, to texture a whole object, you must texture one of its faces, click the Spread button on the

Brush toolbar, then Double-click the face in the Perspective View window. The whole object will
then be textured.

Getting Started

Screen Layout

Screen elements can be grouped in a variety of standard and custom layouts. When you launch I1SB for
the first time, the following Basic screen layout appears:

Main menu Perspective View window Plan toolhar
Standard toolhar Brush toolhar
Camera toolbar
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Eile Edit “Haw Layop Camera Object Tools Hel
D@ Ss(fze] »(me] She] slals)| Blw=le] = <2

Top View
window
Object
gallery
Front Yiew
window
Guide line

e s B =

4|k [y Free camera

The Scane -
&M Froe camera
« R

Plan wheel

ehelll Switch bar

11 o

Pwamidd  Presb lF'l'rsn'ﬂ Curdeizl
*

Bz
r_r| A [ * s Bass B 4]
‘hq.uix-q.ﬁa s TR B =

Material Preview 'Scene Tree
window window

Texture gallery Shape gallery

Status har



Getting Started

By default, this layout includes Perspective View window, Plan window, Scene Tree window, Material
Preview window, Texture gallery, Shape gallery, Object gallery, Standard toolbar, Edit toolbar, and Plan
toolbar.

See also:
* "Screen View Elements” section in ISB's Quick Start Guide document.

TIP:

* You can read the explanation of all ISB menu and toolbar buttons commands for this layout in the
"Reference” section in ISB's Quick Start Guide document.

Customizing layout

The following options are supported in customization:

* You can choose different layouts using the Layout menu.

* |tis possible to enable/disable various screen elements using the View menu.

* The screen elements can be resized and positioned.

* You can also save custom layouts using the List item feature on the Layout menu.

To choose a layout:
* Choose one of the available layouts from the Layout menu. Basic layout is available by default.
You may add new layouts to this set.

To add a new, user defined layout to the set of available layouts in the Layout menu:
1. Customize the screen layout to your desired standards.
2. Choose List from the Layout menu.
3. Inthe dialog box choose Add command and specify the name of new layout.

To resize and change the position of screen elements:
* Drag the window border to set the desired window size.

* Drag the window margin to change its position on the ISB screen.

To customize the toolbars refer to the "Customizing Toolbars” topic of this document.
Notes:

* You may delete the user-defined layout by choosing List/Remove command from the Layout
menu. The default layouts can not be removed.

* |SB saves the layout you used before closing. Thus, restarting the program returns you to the
same layout type, set of visible windows, their sizes and positions, toolbars, which were in place
when you closed the ISB session.

* The scene image in the Perspective view window is resized together with the window, not clipped.
This is similar to viewing a real video camera image on TV screens of different sizes: you always
see the same image, but re-sized to accommodate the screen size.

Working with menus

Working with ISB, you can use the main menu and toolbar commands to create and edit virtual 3D
space. Refer to the “Reference” chapter for the description of all menu commands. You may also use
on-line context help for brief description of commands.

Most of the operations in ISB can be performed in several ways: using the Main Menu, clicking the
Toolbar buttons, drag and drop operations or the context-dependent pop-up menu commands.

To activate the context-sensitive pop-up menu:

* Right-click the item anywhere on the ISB screen. The context sensitive menu appears. The
operation achieved by a Double-clicking the item is displayed in a bold font. Some operations are
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not available for the certain objects and are grayed out. You can get help on each item by
selecting it with the mouse pointer and pressing F1 button.

ISB Scene Building Concept

Scene Building

The fundamental notion describing the 3D space you are creating is the scene. It is actually the world
you create, edit and see in the Perspective View and Plan windows. All items of your virtual space are
inside the scene. As a living 3D space, the scene always exists, and you can not delete or resize it.

Every scene may include a “frozen and the “mobile parts:

* Adding shapes directly to the scene creates the frozen part. Later you can carve them using other
shapes from the scene. But when you add a shape directly everything you do in the scene
becomes unmovable. You can not move or resize these items in the scene itself. See “Example of
stone statue” for illustrating the concept.

* The mobile part of scene consists of objects. Objects can be created by merging and carving with
shapes, imported from ISB’s Object gallery, or directly from geometry files like 3DS files. Objects
can be edited and may include sub-objects, thus forming the Scene Tree (object hierarchy).
Creating objects and establishing the relationship between them, you make the structured scene,
containing information about the world you have created (see “Structured scene”).

* The frozen and mobile parts of the scene are both important for the creation of a 3D world. Read
our comments on how to use them effectively and keep your virtual world clear and easy for
editing (see “Keeping your virtual world clear”).

We recommend you to read these three topics for a better understanding of the ISB world creation
concept.

Example of stone statue

The following example from the real world may help you to understand the concept of a frozen part in
the scene.

* Imagine you decide to make a big stone statue somewhere (a 3D scene in ISB). Although you may
choose any piece of stone, typically you go to some shop (Shape gallery in ISB) and decide what
should be the shape of the piece you would like to buy. After choosing a shape from a set in the
shop you have to decide what shape dimensions are suitable for your statue. For this, you draw a
shape on the plan of your working space (include ready shape into scene operation in ISB). You
may re-draw it several times, changing shape position, orientation, size and proportions (doing the
same in ISB), until you make a decision regarding which piece to order from the shop. After the
piece of stone (shape) has been moved to the place you specified (Add to scene operation), you
can not move it, because it is too heavy. For you, it is frozen and all you can do is to cut a piece
from it or add another. You can not re-size the stone or change its proportions in our real world
through commands or magic. The same is true for the scene in ISB, with the only one difference:
the stone may float in the air, but is still too “heavy to move it.

* Adding a new piece of stone is similar to the above operation. You choose a shape, make a
decision about the position, orientation, etc., and order where to place it (Add to scene). If the new
shape intersects with the existing one, in the real world you would glue the additions to the already
existing shape’s faces. The glue you use is perfect, so the result is a new, solid piece of stone.
After adding the piece, you cannot distinguish between the “old stone and the “new stone. If you
place a separate piece of stone somewhere near the previous one, it is always too heavy to move
it by yourself. In the ISB scene you have the same situation.

* To cut the stone you have to use different tools. First, decide what shape you want to extract from
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the stone. Go to the workshop (Shape gallery in ISB) and select the tool, suitable to cut the cubic,
cylindrical, spherical or other shape you would like to carve in the stone. Then you draw it several
times (place draft shapes into the scene in ISB) on the plan of your statue to define the shape’s
position, orientation and proportions. Finally you use the tool (Extract shape from the scene in ISB)
and cut the piece from the stone. In contrast to the real world, in the ISB scene you may cut the
“stone into several parts, floating in the air, without being afraid that they fall down.

The concept of frozen stones works in the ISB scene. In other words, the ISB program treats the scene
as a set of faces, which do not differ from each other and do not have any history of creation. The model
of frozen stones allows you to simplify the structure of the scene file and reduce its size. The more
complex concept of a Structured scene is described in the next section.

Structured scene

Construction of complex scenes requires that you structure the scene. This allows you to have different
moveable items and to introduce relationships between them. In the “example of stone statue” the
information about scene structure was lost immediately after applying the shape to it.

Now, imagine that you are creating the statue in the bed of a truck. While you are still unable to change
the statue, you can move the statue as a whole in the scene space. In ISB terms, you have defined the
statue as an object, which is now moveable over the scene. The “truck is not visible in the 3D space, but
you can move and turn the object in any direction and even re-size it at any time. While some of this
capability has no direct analogy in the real world, the concept allows you to edit complex scenes easily.
The bed of the virtual “truck (object) has similar properties as the scene itself. The building and editing
rules for the object are the same as for the scene. You may add and extract shapes to/from an object.
As in the scene, you can not resize or move items inside the object separately from each other. The
difference is that now you can move and resize the entire object and save it in the Objects gallery in
order to use it later.

The items inside the object are the same “frozen stones as in the scene. However, you may define a
“secondary truck (sub-object), which can move items over the primary (parent) truck. The rules for
creating and editing items in sub-object are the same as for its parent object. Further more, you may
create third-, fourth-, etc. order “trucks each having the “frozen stones" structure inside and one or more
moveable sub-objects.

The set of objects forms the moveable part of the scene, but this part also has a structure. This means
that each object is a sub-object of some parent object or the whole scene and may have sub-objects
inside. Such relationship is defined by the following rules:

* When any object is resized/moved all its sub-objects and their child sub-objects are re-
sized/moved by the same factor/distance.

* When any object is saved/deleted, all its sub-objects and their child sub-objects are saved/deleted
too.

* The above two operations, when applied to the sub-object, do not affect its higher level (parent)
object.

* Editing of the frozen part of an object does not affect any other object.
* You may change the relationship between the objects freely.

The scheme of relationships between the objects is displayed in the Scene Tree window in the form of a
tree. The root of a Scene Tree is a scene itself. It may have a number of nodes-objects, and each of
them may have sub-objects.

The structured scene concept helps you in editing your 3D space. Imagine you are creating the Galaxy
(scene) with the Sun (object) and the planets (sub-objects) around, among which is the planet Earth with
your house (third level object of Scene Tree). Inside the house you may have a table. When you move
the Sun, you expect that all planets and everything on them move too. You expect also, that the house
where you live stay on ground in the same place while the Earth is moving around the Sun. And you are
sure, that changing or destroying the table in your house does not destroy the Earth or entire Galaxy.
The concept of structured Scene Tree in ISB helps you to keep the relationships between objects
according to the common sense.

Advice on keeping your virtual world clear is located within the next topic.
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Keeping the virtual world clear

The model of structured world in ISB is very useful. You may define the structure and the relationship
between the items in the virtual world in any way you like. However, it is important to keep your virtual
world “clear: the dependencies you introduce must be easy to understand even after returning to the
editing of your virtual world several weeks after its creation. Although it may be humorous enough to
state that the wind is the result of ocean waves, you may forget this joke later and return in your mind to
the common concept. The following notes may help you to keep the space in order:

* When using ISB you are creating virtual world, so you do not have to rely on normal rules of
reality. You can make the Sun a sub-object of the table in your room. However, introducing
“strange dependencies into the Scene Tree makes editing difficult. You may get unexpected
transformations of items or suddenly delete the Sun along with your table. We recommend
keeping the “native order of the objects in your virtual world.

* Although you can make the frozen part of the object complex enough by applying the shapes, we
recommend to create the visually separated items as new objects (see “Create objects”). Doing so
you may easily rearrange them in space and in the Scene Tree as well as save them in the
Objects gallery separately.

* Contrary to what is mentioned above, you should try to make items, consisting of several merged
shapes as a frozen part of single object. In this case the internal, not visible faces of item are
destroyed while applying the shape, thus simplifying the object structure, reducing the file size and
increasing the speed of any VRML 2.0 viewer.

* Be careful creating and importing new objects. Always track their position in the Scene Tree. This
will help you to escape the “strange dependencies and make your virtual world easy to edit.

Two modes of a scene construction

ISB has the two main modes for 3D virtual reality construction. These are: the Scene assembling mode
and the Object editing mode.

The first - Scene assembling mode, is intended for assembling a scene from the different parts prepared
before. These parts can be the frozen scene components, different shapes, objects from the Object
gallery, pictures and movies. In this mode you usually construct the frozen scene parts (using shapes,
textures and colors), and then place into the scene different mobile parts (objects, pictures and movies)
adjusting their size, location, and color and texture attributes. In this mode the whole scene is displayed
both in the Perspective View and Plan windows. The Scene assembling mode is the ISB default mode.

The second - Object editing mode, allows you to construct a new object or modify the existing one to
use during scene assembly. In this mode only the editing object is displayed in the Perspective View
and Plan windows. The whole scene is returned to display mode after the object editing is finished and
the Scene assembly mode is restored. The edited object can be saved in the Object gallery, or placed
into the clipboard or scene.

You can switch between two modes with the Switch bar. Clicking the Scene Plan tab switch ISB in the
default Scene Assembling mode, while clicking the Object Plan tab enters the Object Editing mode.

TIP:

You can learn more about building the scenes with the help of “Examples”, given in ISB's Quick Start
Guide document.

Editing objects in the Object Editing mode

To enter the Object editing mode do one of the following:

* Choose Edit on the Object menu to edit the current scene object
* Choose New Empty Object on the Object menu to create a new object
* Double-click an object in the Object gallery to edit the selected object

. il Click New Object on the Edit toolbar
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Ohiect FIan_} click Object Plan tab in the bottom of the Plan window to edit the selected object.

After switching to the Object Editing mode, images of all the objects are removed from the Plan and
Perspective View windows except the currently selected object and its sub-objects. The plan scale for
the object is adjusted automatically, and the Go To Object command of the Camera menu is executed.

To edit the object you can use the Object manipulator, the Ruler, and shapes.
After the editing is finished:

\‘M Click the Scene Plan tab to return to the Scene Assembling mode:

* If an object edited is not yet in the scene, the Save object dialog box is presented for choosing a
saving mode. See the Create objects section to learn detailed methods for saving objects.

* If the object edited is already present in a scene, the scene will be restored in the Plan and
Perspective windows. See the Saving object section to learn how to save a changed object to the
object gallery.

See also:

“One level house” example in the ISB's Quick Start Guide document.

Galleries of Already Built Items and Examples

Galleries of ready items in ISB

The ISB compact disk contains not only the executable program, but also a rich collection of pre-built
items, located in the Galleries of Scenes, Objects, Pictures, Textures and Movies.

All items in the Scene and Object galleries were built with ISB. You may load the ready scenes to see
the capabilities of ISB. While viewing the scenes, you may also see their internal structure in the Scene
Tree window. Note, that most of the scenes contain both the frozen and the mobile parts (objects).
Explore the scene structure to learn more about how to build your own scenes.

The items in the scenes of the Scene gallery are painted with colors and textures. However, all scenes
are also saved as non-colored objects in the Examples category of Object gallery. So, if you want to
start building your 3D space with the ready-made “house you may place the corresponding object from
the Object gallery into your new scene and apply the colors and textures to its faces in any way you like.
Aside from the Examples category, the Objects gallery also contains two more ready categories:
Furniture and Plants, which are the collection of 3D furniture items and plants.

How does ISB store the files of galleries

If you purchase ISB 3.0 on CD ROM, the way, in which the ISB program stores and saves the contents
of its galleries (resources), depends on the type of installation:

* For a Typical installation, the files of all galleries are copied and stored in the correspondingly
named sub-directories of the main ISB directory on your hard disk. For the galleries, which are
divided into several categories, all items are saved into the sub-directory of the gallery directory.

* Using the Compact installation, all files from the galleries, except the Shape gallery are stored on
the compact disk.

* With the Custom installation you may choose the galleries, and therefore which files will be copied
to the hard disk.

Note:

* All newly created or edited items (Scenes, Objects, Pictures, Textures and Movies) are saved in
the sub-directories of the ISB directory, regardless of the type of installation of the ISB program.
So every time when you edit an item, the corresponding file with modified item is copied to the
gallery’s sub-directory on your hard disk.
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Phases of building the virtual space

The ISB compact disk contains an example of phased building - a virtual 3D house. Look in the directory
ISB\Scenes\Phases for files Phasel-6.wrl. These scenes illustrate the process of building a virtual
home. The final project is presented in the main Scenes gallery with the name Los Gatos. Phases 1 to 6
show the structure as it gets more and more complex by adding more faces to the frozen part of the
scene. More cameras are added for viewing the scene, and later one object is added as an example of
a mobile part of the scene. Look at the phases for a better understanding of the scene building concept.

Related topics:

* Main scene parts
* Frozen part of scene description and example
* Structured Scene description and example

Basic Operations
Creating, Opening and Saving 3D Scenes

Create a new scene

To create a new scene:

. El Click New on the Standard toolbar or choose New from the File menu. A new scene is
created. All its parameters, such as camera position, grid spacing, etc. are set by default.

You can specify landscape, background colors and panorama images for a new scene.
To set these properties for a new scene:

1 Choose Set Background command on the File menu. A dialog box appears.

2 Choose the background scheme from a list of available schemes. Select what items: background
colors, textures, and landscape from the scheme will be used in the scene you are creating.

3 Edit the Ground and Sky colors, if necessary.

Note:

You can change the background settings for any existing scene at any time you like. The background
settings are saved in the scene file and will be shown while viewing the scene by VRML 2.0 browser.

Open an existing scene

You can open a scene from a file or choose one from the Scene gallery.

To open a scene from a specified file:

S
. Iil Click the Open button on the Standard toolbar or choose Open from the File menu. A new
scene is opened and is shown in the Perspective View window. The plan is displayed in the Plan
window.

Note:

The following formats are supported: VRML 2.0 and MUS (the Virtual Home Space Builder format).
If a scene in the VRML 2.0 format contains data on a camera’s position, it is placed in this position
or at the scene coordinate system origin by default. The scene in the MUS format does not contain
information on the camera'’s position, and the camera assumes the default position.
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To choose a scene from the Scene gallery:

1 Iil Click the Choose button on the Standard toolbar or select Choose from the File menu. The
Scene gallery is displayed.

2 Look through the gallery to find the required scene.

3 Double-click the desired scene or drag it to the Plan or Perspective View window. The scene is
opened and is shown in the Perspective View window. Its plan is displayed in the Plan window.

Save a scene

To save a hew, unnamed scene:

1 El Click the Save button on the Standard toolbar or choose Save from the File menu. A dialog
box for the file name appears.

2 Specify a file name for your scene.
To save the scene in other than the default ISB Scenes folder, click a different drive name or folder
name. For example, if ISB is installed in C:\ISB, its default scene folder is C:\ISB\Scenes. The
scenes located in the ISB scene folder are automatically included into the Scene gallery.
In the File Name box, type a nhame for the document.

3 Select the VRML 2.0 item in the Save as type list box to save the scene in the VRML 2.0 format or
choose the VRML 2.0 compressed item to save the scene in the VRML 2.0 compressed (gzip)
format. Note that both options create the files with the same extension .wrl. VRML 2.0 browsers
automatically identify compressed file format.

4 Click Save.

To save an existing scene:

¢ Choose Save on the File menu or

Click Save on the Standard toolbar or

* Drag the scene from the Scene Tree window to the Scene gallery.

Controlling Camera

Control cameras

* Cameras are used to view a scene in the Perspective View window. Any number of cameras can
be used. Only one camera can be active at any time. A scene is viewed through the active

camera. Each camera is represented in the Plan window with the Mﬂ' Pinocchio icon.

In a 3D scene, a camera has six degrees of freedom. You can move it in X, Y, and Z directions. You can
also change its orientation:

* Yaw - it appears as if you are turning your head to the left or to the right.
* Pitch - it appears as if you are lifting your head up or drop it down.
* Roll - it appears as if you are inclining your head to the left or to the right.

The camera’s movement and orientation are reflected in the Plan window. During the movement and
rotation of the active camera, the view in the Perspective View window changes accordingly.

11
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Navigate cameras in the Plan window

To move a camera along a plan:

o A Position the pointer over the Pinocchio icon. The pointer looks like a camera.

* Drag the Pinocchio icon in the desired direction. Note:
You may navigate the camera through walls while moving in the Plan window.

To change a camera’s orientation:

.0
. Position the pointer over the Pinocchio icon. The pointer looks like a camera.

* Rotate the Pinocchio icon tip with your mouse (yawing in the Top View window, pitching in the
Front View window).

To place a camera in a required position:

* Double-click the desired position in the Plan window. The active camera moves to that location. Its
position is changed in the Top and Front View windows.

See also:
* "Viewing 3D Scenes” example in the ISB's Quick Start Guide document.

Navigate active camera in the Perspective View window

To control the active camera in the Perspective View window:

* Click anywhere in the Perspective View window. Now you can move and rotate the active camera
using the mouse or keyboard.

To control the active camera using the mouse in the Scene assembling mode:

* Move the mouse in the desired direction while holding down the left mouse button:

Forward — move closer  Shift+forward — move up Ctrl+forward - turn up
Backward — move Shift+backward — move Ctrl+backward - turn
further down down
Right - turn to the right Shift+right - move to the

right
Left - turn to the left Shift+left - move to the left

To control the active camera using the mouse in the Object editing mode:
* Move the mouse in the desired direction while holding down the left mouse button:

Forward/Backward Shift+forward/Shift+backward -  Ctrl+forward/Ctrl+backward -
— move camera move camera around the turn camera up/down
closer/further to the  object in the vertical plane

current object

Right/Left — move Shift+right /Shift+left- turn Ctrl+right/Ctrl+left - turn
camera around the camera to the right/left in the camera to the right/left
object in the vertical plane

horizontal plane

* Double-clicking a face in the Perspective View window directs the active camera to the face and
brings it closer to the scene.

12
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You can control the active camera using a keyboard commands. ISB allows to re-define the keyboard
keys assignment for the keyboard navigation. The default assignments in ISB are:

e Arrow Up - move closer,

e Arrow Down - move further;

* Arrow Right - move to the right;

e Arrow Left - move to the left;

e PgUp - turn to the right;

¢ Home - turn to the left;

e Gray Plus - move up;

e Gray Minus - move down;

* 1 on the alphanumeric keyboard - incline to the left;
e 2 on the alphanumeric keyboard - incline to the right;
* 3 on the alphanumeric keyboard - turn up;

* 4 on the alphanumeric keyboard - turn down;

* T -increase a focal length;

* W - decrease a focal length.

To accelerate the camera’s movement/rotation:
* Press Shift and one of the above keys simultaneously.

You can make your own key assignments for the keyboard navigation as well as set the velocity and
acceleration factor for the keyboard navigation using the Keyboard Navigation dialog box.

Note:

You may not move a camera through walls while moving in the Perspective View window while the
“collider is on. To turn the collider on/off click Use Collider on the Camera menu. You can also turn
the collider on or off by clicking the Collider button on the Camera toolbar.

See also:

"Viewing 3D Scenes” example in the ISB's Quick Start Guide document.

Navigate active camera in the Ruler window

a3l P

The active camera is controlled in the Ruler window by using the Camera icon.

This icon has a handle with two rings: the left one is used to move the camera, the right one to change
the camera’s orientation. You can also change the focal length of the camera’s view.

To control the active camera in the Ruler window:
7 1

—

. Position the pointer over the Camera icon. The camera picture appears below the
pointer.

To move the active camera up or down:
* Drag the Camera icon using the left ring

13
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To turn the active camera up or down:
* Drag the Camera Icon using the right ring.

To change a focal length of the active camera:

. +'ﬁ Click More Tele button on the top of the Ruler window to increase the focal length.

. W Click More Wide button on the top of the Ruler window to decrease the focal length.

See also:
* "Viewing 3D Scenes” example in the ISB's Quick Start Guide document.

Align cameras

To position the camera’s horizontal axis parallel to the scene horizontal:

. Iﬁl Click Align Horizontal on the Camera toolbar or choose Align Horizontal on the Camera
menu.

To position the camera’s longitudinal axis parallel to the scene horizontal:

[ . . . . .
. _jl Click Align Vertical on the Camera toolbar or choose Align Vertical on the Camera menu.

Duplicate cameras

To duplicate a camera do one of the following:
¢ Double-click the camera icon in the Plan window.

. Click Duplicate on the Camera toolbar.
* Choose Duplicate on the Camera menu.

* Drag and drop the camera into another object in the Scene Tree window while holding down the
Ctrl key.

The new camera has the same location and orientation as the one you've just duplicated.

Set active camera

To set an active camera do one of the following:

* Click the corresponding Pinocchio icon in the Plan window.
* Double-click the camera name in the Scene Tree window.
* Click the camera tab in the Perspective View window with the name of camera to be activated.

The Pinocchio icon of the active camera is colored red in the Plan window. Its icon in the Scene Tree
window is marked with a red box. The camera name in the Perspective View window camera tab is
shown in bold font.

Rename cameras

To rename a camera:
1 In the Scene Tree window, right-click the name of the camera you want to rename, and after a

pop-up window appears, choose Rename. Or, in the Scene Tree window you can click twice the
name of the camera you want to rename. Or, in the Perspective View window you can Double-click
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the camera tab. The edit box for the camera name appears.
2 Enter the new camera name and press Enter.

Note:
The Free camera is assumed to belong to the scene. This camera cannot be removed.

Delete cameras

To delete a camera:

1 Right-click the Pinocchio icon in the Plan window or right-click the camera’s name in the Scene
Tree window. A pop-up window appears.

2 Choose Delete.

Note:
The Free camera is assumed to belong to the scene. This camera cannot be renamed.

Constructing Scene

Construct scene

ISB enables you to build a scene with complex shapes, rather than with individual polygons.

A shape is the basic unit for a scene construction. A shape represents a solid object. It can be as simple
as a rectangle, or a cone, or it can be as complex as an entire scene. ISB allows you to easily
manipulate shapes of any size.

The construction process consists of three steps:

* Including a shape into scene. As a result, a draft of the shape is shown in the Top View, Front
View and Perspective View windows. The scene is not changed.

* Adjusting shape size, position, and orientation with the help of the Shape Manipulator (see “Set
shape position, size and orientation”).

* Applying the shape to the scene using the_Add, Extract, Cut or Copy operation. When this step is
completed, the scene is changed.

A shape may be taken from the Shape gallery or built on the fly.
Related topics:

* Include ready shapes into a scene.
* Include shapes created on the fly.

TIP:

You can learn more about building the scenes with the help of “Examples”, given in ISB's Quick
Start Guide document.

Include ready shapes into a scene

To include a ready shape into a scene:

1 il Click Build Mode on the Plan toolbar. The pointer ;Q? looks like an arrow with a hammer
near it.
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+ -

2 ¥ Frisié Drag the shape into the Top View window. The pointer looks like a shape with an

arrow while dragging it.
Or, you may click the shape in the Shape gallery and draw a bounding box for it in the Plan

window.

Note:

To draw a box, click anywhere in the Top or Front View window, then hold down the left mouse
button, draw a box and release the button.

TIPS:

To replace a shape, Double-click another shape in the Shape gallery. You may do this only when a
shape is included into, but not yet applied to the scene (Add, Extract, Cut or Copy operations have
not yet been made).

A draft shape (on the Plan window but not added yet) is replaced by another one if you draw a new
rectangle in the Plan window or accidentally left click there while moving the mouse. This incidental
draft shape can be deleted by pressing the Esc key.

Include shapes created on the fly

You can create shapes on the fly using a polygon or closed curve inscribed into the polygon.
To create a shape using a polygon and to include it into a scene:

1 Iﬁl [%Q Click Polygon Mode on the Plan toolbar. The pointer looks like a polygon with an
arrow.

2 Specify polygon vertexes in the Top View window.
To specify a vertex, click somewhere in Top View window. A new vertex with edges connecting it
to its neighbors is created.

- %) To move a vertex - drag the vertex onto another place.

To insert a new vertex between the existing ones - click between them, the edge connecting the
two vertexes is deleted, a new vertex is inserted, and two new edges are created.
To delete a vertex - right-click it and when a pop-up menu appears, click the Delete Vertex item.

3 Click either Solid EI , Walls E‘ , Room El , or Pyramid E‘ button on the Edit toolbar

depending on the shape you want to create. The walls, ceiling and floor have default thickness. To
change default thickness, use Options on the Tools menu.

To get an opportunity of using a closed curve include (see “Add of delete toolbar button” for details) the
Spline Mode button into the Plan toolbar, and Increase Smoothing, Decrease Smoothing, Increase
Tension and Decrease Tension buttons into the Edit toolbar using the Customize item on the Options
menu.

To create a shape using a smooth curve and include it into a scene:

1 Q Q Click Spline Mode on the Plan toolbar. The pointer looks like a smooth loop.

2 Specify polygon vertexes in the Top View window.
To specify a vertex, click somewhere in the Top View window. A new vertex with edges connecting
it to its neighbors is created. The smooth curve inscribed into the polygon is displayed:

To move a vertex - drag it into another place.

To insert a new vertex between the existing ones - click between them, the edge connecting the
two vertex is deleted, a new vertex is inserted, and two new edges are created.

To delete a vertex - right-click it and when a pop-up menu appears, click the Delete Vertex item.

4 Click either Solid EI , Walls E‘ , Room EI , or Pyramid E‘ button on the Edit toolbar

depending on the shape you want to create. The walls, ceiling and floor have default thickness. To
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change default thickness, use Options on the Tools menu.

TIPS:

If you want polygon vertexes to snap to the grid cells, complete the following before creating a new
shape: Choose Options from the Tools menu. When the dialog box appears click the Plan tab. In
the Grid section, mark both the Active grid and Visible grid checkboxes. Choose a ratio to change
the coordinate points in the scene plan. For example, a ratio of 1:5 means that the coordinates of
any shape’s vertex are 1/5th the grid ratio.

To chan?e the curve smoothness:
@l @Il Click the Increase Smoothing or Decrease Smoothing button.

To draw the curve closer to the polygon vertexes:

@ @ Click the Increase Tension or Decrease Tension button.

Set shape position, size and orientation

The following picture shows the Shape Manipulator controls:

—Hesize jack
- Lever

#Mwing point

To set a shape position:

. (%) Drag the Shape Manipulator’'s moving point. The moving point coordinates are seen on
the status bar while moving. You can move a shape in any of the three dimensions. Use the top
view window to move in the horizontal direction and the front view window to move a shape
vertically and along one of the horizontal axes.

To set a shape size:

° lfl Drag the Shape Manipulator’s resize jack. Three values that specify the shape’s bounding
box are shown on the status bar. The first and second values are the coordinates of the bottom left
corner of the bounding box. The third value is the bounding box size in the direction defined with
the lever. To define a shape’s horizontal dimensions, manipulate the top view resize jack. To
define a shape’s vertical dimensions, manipulate the front view resize jack.

To set a shape orientation:

]FD

o (—) Drag the Shape Manipulator’s lever. To rotate the box in the horizontal plane, rotate the top
view. To rotate (incline) the box in the vertical plane, rotate the front view.

To skew a shape:
* Drag the Shape Manipulator's moving point while holding down the Shift key. The center of the
shape’s bounding box will drag with your pointer’'s movements. During deformation the lowest face

of the shape at the point it was included into scene remains unchanged, irrespective of shape
rotations.
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To achieve smooth shape rotation:
* Hold down the Ctrl key while rotating.
To resize a shape in all dimensions at once:

* Press Gray + key on the numeric key pad to increase the size of the shape or Gray - to decrease
the size of the shape.

See also:

"Simple House” example in the ISB Quick Start guide document.

Apply shapes to scene

You can use Add, Extract, Cut or Copy operations to apply a shape to a scene. If you define the scene
structure using objects, please take into consideration that a shape is applied not to the whole scene but
to the current object only.

After part of the scene is brought onto the clipboard using the Cut or Copy operations, it can be pasted
elsewhere in any scene.

To add a shape to a scene:

. @ Click the Add button on the Edit toolbar or choose Add Shape on the Object menu.

To extract a shape from a scene:

. Xl Click the Extract button on the Edit toolbar or choose Extract Shape on the Object menu.

To cut part of a scene onto the clipboard:

. il Click the Cut button on the Standard toolbar or choose Cut on the Edit menu.

To copy part of a scene onto the clipboard:
Ep
. Click the Copy button on the Standard toolbar or choose Copy on the Edit menu

Note:

The Extract, Cut and Copy operations are unavailable for the Room and Wall shapes, and for non-
convex shapes created with the Record Shape command of the Tools menu.

To paste an object previously placed onto the clipboard, do one of the following:
. Igl To paste it in the position, from which you have placed the item onto the clipboard before,
click the Paste button on the Standard toolbar or choose Paste on the Edit menu.

* To paste it on a particular face of any item in the scene, right-click the face in the Perspective View
or Plan window. After the pop-up window appears, choose Paste.

Controlling Shape Heights

Control shape heights

Each shape you include into a scene is assigned a default size and position. You define default height
using the guide lines of the Front View window. After a shape is included you can change its position
and size with the help of the Shape Manipulator. The top view Shape Manipulator is used to control the
shape’s horizontal dimensions and position while the front view Shape Manipulator is used to control the
shape’s vertical dimensions and position.
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If you have an experience of constructing scenes with VHSB and prefer to work without the front view,
you can use the Ruler window (). Here you control the height and vertical position of a shape with the
help of the Ruler’s laths and Guide lines shown in the Ruler window.

by ———————Top Guide line
- Ruler scale
| ————Gray Ruler

I:Z \
7 Eﬁ'—ﬂamera icon
] / —>=—Camera's manipulators

Red ruler

_ Ruler heght control lath
—f==——— Bottom Guide line

Top Guide line. It defines the vertical position of the top face of the shape bounding box when included
into the scene.

Ruler scale. Shows the camera and objects vertical position in meters.

Gray Ruler. Corresponds to the shape currently included into a scene but not yet applied. With the help
of the gray Ruler, you can set the height for this shape.

Camera Icon. Shows the vertical position and orientation of the current camera in the Ruler window.
Camera’s manipulators. To move the active camera up or down, drag the Camera icon using the left
ring. To turn the active camera up or down, drag the Camera Icon using the right ring.

Red Ruler. Corresponds to the current scene object. With the help of the red Ruler, you can change the
height of the current object.

Ruler height control lath. The top and bottom laths of the Ruler define the position of the top and
bottom faces of the shape or object bounding box.

Bottom Guide line. It defines the vertical position of the bottom face of the shape bounding box when
included into the scene.

To turn the Ruler window on/off:

. 1-‘ Click Ruler on the Plan toolbar. The Ruler window is displayed when the Ruler button is
pressed. The Ruler window is hidden if the Ruler button is not pressed.

Set shape’s default height

The default height of a shape (when included into the scene) is set using the Guide lines shown in the
Front View and in the Ruler window. The top guide line defines the vertical position of the top face of the
shape bounding box. The bottom guide line defines the vertical position of the bottom face of the shape
bounding box.

To turn Guide on/off:

1 Right-click anywhere in the Plan window. A pop-up menu appears.
2 Check Guide to turn the Guide on or clear it to turn the Guide off.

To see the guide line height and the distance between the two guides:

1 - - b position the pointer over the guide line for a height description. A guide line crossed with a
double arrow appears near the pointer.

2 Click the line. Its height and the distance between the two guides are shown on the status bar. All
values are given in meters.

To move a guide line:
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T

1 - - b position the pointer over the guide line to be moved. A guide line crossed with a double
arrow appears near the pointer.

2 Drag the guide line up or down. The line’s height and the distance between the two guides are
shown on the status bar. All values are given in meters.

Change shape heights

Two Rulers can be shown in the Ruler window:

* The gray Ruler corresponds to the shape currently included into a scene but not yet applied. With
the help of the gray Ruler you can set the height for this not yet applied shape.

* The red Ruler corresponds to the current scene object. With the help of the red Ruler you can
change the height of the current object.

The top lath of the gray Ruler defines the position of the top face of the shape bounding box. The bottom
lath of the Ruler defines the position of the bottom face of the shape bounding box.

To move the Ruler’s laths:

. -:’/' Position the pointer over the lath. The pointer looks like an arrow and a hammer.
* Drag the lath up or down.

Scroll the Ruler

There are two ways to scroll the ruler: You may scroll the Ruler smoothly or move it by half a point.

To scroll the Ruler smoothly:

* Hold down the left mouse button somewhere in the Ruler window and drag it up or down. The
Ruler is scrolled in this direction.

To scroll the Ruler by half a point:

e Click Scroll Up LI in the Ruler window to scroll the Ruler up, or click Scroll Down LI to
scroll it down. The Ruler is scrolled by half a point in the desired direction.

Creating New Shapes

Create custom shapes

ISB can remember the steps made during a scene construction and repeat them to create a custom
shape in the Shape gallery. You can construct a new shape using ready made shapes from the Shape
gallery or from shapes built on the fly.

To record and create a custom shape:

r o . . .
1 - Choose Record Shape from the Tools menu. The pointer looks like a cassette tape with a
hammer and an arrow.

2 Create a custom shape.

3 Choose Stop from the Tools menu. The sequence of operations between the Record Shape and
Stop commands is retained. The dialog box for custom shape specification appears.

4 In the field Name specify the name of the file for the new shape.
5 In the field Title specify the gallery name of the shape.

6 In the field Category specify the name of the tab in the Shape gallery where you want to save your
shape. You can define a new tab name or use the existing one.
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Note:

While recording the shape you are actually recording the macro sequence of commands for its
creation. So when you apply the recorded shape to the scene the result is the reprodustion of all
actions you made while recording, including Extract operations with large shapes. This may affect
surrounding shape items.

Manipulating Plan

Split the Plan window
To split the Plan window when it shows the Top View only:

=
1 j Position the pointer over the splitting box in the upper right corner of the top view. The pointer
looks like a double line with two arrows.

2 Drag down the splitting box. The Plan window is spliced, and the front view window is displayed.

To change the Plan window splitting:
4.
1 “F 7 Position the pointer over the splitting line of the Plan window. The pointer looks like a
double line with two arrows.

2 Drag the splitting line up to make Top View smaller and Front View larger or drag it down to make
Top View larger and Front View smaller.

Turn the Grid on/off

The Grid is shown in the Plan window by default.
To turn the Grid on/off:

1 Right-click anywhere in the Plan window. A pop-up menu appears.
2 Check Grid to turn the Grid on or clear it to turn the Grid off.

Rotate a plan

2 The scene plan contains only two views: the top view and front view. While
constructing a scene, it is sometimes necessary to adjust the direction of the axis for the plan projection
we call the front view. ISB allows rotation of this axis at any angle in the horizontal plane of a scene. To
rotate the plan, use the Plan wheel shown on the bottom of the Plan window. The top view plan rotates,
while the front view plan changes depending on a change in the direction of its projection axis.

You can rotate the Plan wheel with your pointing device. The rotation angle is shown on the status bar.
Each point of the Plan wheel is equal to 6 degrees. Rotation of the wheel to the next longer mark
corresponds to a rotation by 30 degrees. Rotation of the wheel to the next bold mark corresponds to a
rotation by 90 degrees.

To rotate a plan:

1 Position the pointer to the Plan wheel, then hold down the left mouse button.

2 Rotate the Plan wheel by moving your mouse in the opposite direction desired to rotate the plan.
For example, for the left plan view, rotate the Plan wheel to the right until its next black mark fits
the red triangle.

3 Release the mouse button.

Notes:

* To get a smooth rotation, hold down the Ctrl key while moving the mouse.
* The coordinate grid does not change as you change the projection axis of the plan rotation. A new
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draft shape will be oriented towards the axis of the coordinate grid, not the plan rotation and
appears turned to the same angle as the projection axis. Therefore, to turn the shape precisely to
a specified angle on the top view, you can first turn the plan with the wheel, include the draft shape
into it, and then restore the rotation angle to the initial position.

* To restore the plan and Plan wheel initial positions:
Double-click the wheel. The rotation angle shown on the status bar is equal to zero.

Scroll a plan (pan the view port)

Besides scrolling a plan using the ordinary scroll bars of the Plan window you may also use the Moving
Plan mode. In this mode both views are scrolled at once by moving your mouse.

To move plan views:
1 @ Click Moving Plan on the Plan toolbar.

2 . @_n] Position the pointer anywhere on the Plan window. The pointer looks like an arrow with a
hand below it.

3 Hold down the left mouse button and move the mouse in the direction desired. Both plan views are
moved simultaneously.

4 Release the mouse button. The Moving Plan mode is turned off. The Build mode is restored.

Zoom of plan

To increase view magnification:

. @”' Click Zoom In on the Plan toolbar. The two plan views magnification is increased.

To reduce view magnification:

. a’" Click Zoom Out on the Plan toolbar. The two plan views magnification is reduced.

To magnify a selected part of a plan:

. q" Click Zoom Mode on the Plan toolbar to turn on the Zoom mode. In this mode you can select
a particular area in the top or front view to zoom in on.

. 4@ Select an area to zoom in on. To select an area, hold the left mouse button anywhere in the
Plan window, draw a corresponding rectangle, then release the button. The area is immediately
magnified in both views.

Note:
The grid can be hidden as a result of zooming.

Fit a window to a scene

To make both scene views fully visible in the Plan window:

o El Click Fit to Scene on the Plan toolbar.

Notes:
* If only one view is displayed then only that view is fitted to the window. The scene may not fit in the
other view when it becomes visible.

* The rectangle parallelepiped includes all scene parts as well as cameras. Its dimensions are taken
as the overall scene size on the plan. Therefore, the plan’s scale is set so that all elements of the
scene can be seen.
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Print a plan

To print both plan views:
. @l Click Print on the Standard toolbar or choose Print on the File menu.

Note:

* The printer output should look the same as the current Plan Window configuration, including the
presence and relative size of top and front views.

Using Shapes in the Perspective View Window

Placing shapes in the Perspective View window

When you include shape into the scene by dragging it in the Plan window a gray semi-transparent
shape appears also in the Perspective View window. This allows you to adjust the shape position
relative to the items directly in 3D space. You can also include a shape into the scene by dragging it
directly in the Perspective View window:

1 Position the camera to make visible an item already present in the scene.
+

2 ¥ Frisié Click the shape you would like to apply to scene and drag it in the Perspective View
window. The pointer looks like an arrow with the shape icon and name near it.

Position the pointer on the face, on which you decide to place the shape. If you point to the
empty space the pointer shows that including shape operation is not available.

4 Release the mouse button. The shape is placed exactly onto the face of visible item in the
Perspective view window. All shapes in the Shape gallery have one face, marked as its bottom
face. When you drag the shape onto the face in the Perspective View window it is automatically
positioned to “touch the target face by its own bottom face. This is useful if you decide to apply the
shape to the existing scene and position it exactly on the ground landscape (for details, see
“Scene background schemes: overview”) surface.

The picture to the left illustrates the shape, included into
the scene with Desert background scheme as a first step
of building a house. The bottom face of the shape is only
touching the ground surface, but not going through it. You
can change the shape size, position and orientation using
the Shape manipulator in the Plan window or using Shape
manipulator in the Perspective View window.

Note:
* All shapes in the Shape gallery have some face, defined as bottom face. Even Sphere shapes

have their bottom faces. This allows setting of complex shapes, like the sphere, onto the face in
3D space in the same way as for the other shapes.
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Set shape position, size and orientation in the Perspective
View window

When you include shape into the scene by dragging it in the Plan or Perspective View window it is
shown in as gray semi-transparent shape in the Perspective View window:

Resize jack

Moving point

Shape manipulator
rotation arm

Resize jack
Drag this point to change the shape’s size in the direction, defined by the manipulator arm.
Shape manipulator rotation arm

Moving point
Drag this point to move the shape to another place in 3D space. The shape moves in the plane, parallel
to the Perspective View window plane.

Shape manipulator rotation arm
Drag this arm to turn the shape. The shape is turned around one of the other arms. The rotation axis is
set automatically according to the direction of first pointer's motion.

You can adjust the shape position, size and orientation relative to the items directly in 3D space Using
the Shape manipulator in the Perspective View window. The picture above illustrates the Shape
included into the scene and its Shape manipulator.

Several rules are applied while you change the shape dimensions or position using the Shape
manipulator in the Perspective View window:

* While you move the shape, it always moves in the plane, parallel to the Perspective View window
plane. In other words, if you change the camera orientation you also change the shape motion
plane orientation.

* While you resize the shape it grows/shrinks so, that its bound box, opposite to the resize jack you
are currently dragging keeps its position. This ensures that after you have placed the shape onto
the face it remains exactly touching the face while you resize the shape dragging its resize jacks,
not located on its bottom face.

* You can choose the rotation axis while rotating the shape in the Perspective View window by
making the first mouse movement very carefully and choosing its direction looking parallel in three
dimensional space to the Shape manipulator arm, around which you do not want to rotate it. This
sounds little bit confusing, however you can get good practice after several attempts.

TIP:

To make setting the shape position and orientation easier, always try to set the camera viewing
position to make all Shape manipulator arms displayed in the Perspective View window going in as
much as possible different directions. The example of suitable camera viewing position is given on
the picture above.
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ISB Limits

Several restrictions exist regarding the size of scenes, shapes, and objects, and the scale of a plan.
Maximum size of a scene: 1000 m (1km).
Minimum size of a shape or object: 0.01m (1cm).

Minimum scale of a plan: 0.001 m/pixel (Imm/pixel).
Maximum scale of a plan: 10m/pixel.

Scene Background and Landscape

Scene background schemes: overview

hap viewr

side view

Each scene you are creating or editing may contain background color, background texture images and
landscape. Combinations of these three components are grouped in several background schemes. You
can chose to apply to your scene any component from any background scheme.

e Background color. Background color is used to paint the scene background with colors to
simulate the sky and the ground colors. The background color is displayed as if the camera is
located in the center of a very large sphere. The sphere is always moving together with the
camera keeping it in the center, so you can not come close to the sphere. The sphere is painted
with color circles, each circle is defined by the angle from the Zenith (straight up) viewing direction.
You can specify the color for each angle value. The color of rings between the specified angles is
changing gradually (interpolated). For example, to simulate the sunset sky color you can set the
zenith color as dark blue and the horizontal plane color and red. The sky sphere color will change
gradually from red to blue while you are looking higher and higher turning the camera up. You can
specify the sky color for the angles below the horizon down to the Nadir (straight down) viewing
direction. This is useful when you are building the scene without ground, e.g. open space. For the
scenes containing ground you also can specify the ground half-sphere color. If the ground color is
specified, the background colors below the horizontal plane are shown according to the ground
color settings and the sky colors are ignored. There is sharp horizontal border between the sky
and the ground. The picture above, taken from the VRML 2.0 language description, illustrates the
background color settings.

e Background textures. When you use the background colors you always get the same color when
you turn the camera around the vertical axis. To simulate the natural sunset you have to specify
the scene background images for different viewing directions. In ISB you can apply textures to
faces of very large cube, inscribed into the sky sphere as shown on the picture above. The cube is
always moving together with the camera keeping it in the center, so you can not come close to the
cube face. The textures are prepared in a special manner eliminating the visibility of borders
between the cube faces and producing the effect of a sphere with an image on it. If a transparent
color is used in the texture then the sky and ground colors are also visible through the texture
image. The combination of background color and background textures allows to create
sophisticated and impressive Scene backgrounds.
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* Landscape. The scene may contain not only the background but a landscape. Landscape
simulates the ground relief and may be flat as well as imitate mountains. You can choose the
landscape from a set of available landscapes from any background scheme delivered with ISB.
You can not edit the landscape. However you can place scene items on the landscape surface
and apply texture to the landscape. All landscape surface is treated as a single face, so when you
apply a texture all landscape is textured as a whole. The texture image is stretched to apply to the
whole landscape without tiling by default. You can map the textures applied to the landscape using
texture mapping operations.

See also:

“Using Background schemes” example in the ISB Quick Start Guide document.

Setting the scene background and landscape scheme

You can set the background properties scheme for any scene you are editing. After you have set the
background scheme, you can change it at any time.

To set and edit the scene background scheme:

* Choose Set Background on the File menu. A dialog box shown on the picture below appears.

In this dialog box you can:

* Choose the background scheme from a list of available schemes

* Select which components of the scheme will be used in your scheme

* Set the current scheme as default background scheme for all new scenes in ISB

» Edit the background colors for the sky color and the ground color

* Preview the results of editing the background in the Preview section of the dialog box
* Apply the editing operations to the current scene

The following explains all controls in the Background dialog box:

Background

Scheme: |SunSet [testured] ﬂ v SkyColor — M Ground Calor

Settings to be applied

W Colors [ Jestures [ Landscape

e

G +— 209
E 1 47

1

[ Set az default for a new scenes oK | Carcel Apply Help

Background Scheme. Select the background scheme from a list of available schemes.
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Save as button. Click this button to open standard Save As dialog to save the background scheme you
have created under a new name.

Sky color. Check this item to edit the Sky color. You can set the sky color for every angle above and
below the horizon. Note that if the Ground color item is checked the sky color below the horizon is not
visible.

Ground Color. Check this item to edit the Ground color. You can set the sky color for every angle below
the horizon.

Settings to be applied area. You can apply the scheme settings for Colors, Textures and Landscape in
this area.

* Colors. Place mark near this item to replace the current Scene background colors with colors,
specified in the new scheme. If this item is not checked, the colors from the new scheme do not
substitute the current colors.

* Textures. Place mark near this item to replace the current Scene background textures with
textures, specified in the new scheme. If this item is not checked, the textures from the new
scheme do not substitute the current textures.

* Landscape. Place mark near this item to replace the current Scene landscape with the landscape,
specified in the new scheme. If this item is not checked, the landscape from the new scheme does
not substitute the current landscape.

Preview background window. You can preview the scene background in this window. While viewing
you can turn the camera in vertical and horizontal planes to observe the background for any viewing
direction.

To turn the camera in the vertical plane:

* Drag the Vertical rotation slider control located to the right from the Preview window, or

e Click anywhere in the window and move the mouse pointer vertically, holding down the left mouse
button.

Vertical rotation slider control. Move this slider to turn the camera in the preview window in the
vertical plane. The top of the slider, marked with Z character corresponds to zenith (straight up) viewing
direction, the middle of the slider - to horizontal viewing direction and the bottom mark N - to the nadir
(straight down) viewing direction.

Horizontal rotation slider control. Move this slider to turn the camera in the preview window around
the vertical axis. The middle mark of the slider corresponds to the forward viewing direction while the

edge marks of the control correspond to the backward direction. The marks to the left and to the right
from the middle mark correspond to 90 degrees rotation angle to the left and to the right, respectively.

Color distribution bar. This bar shows the background color distribution from zenith (top of the bar) to
nadir (bottom of the bar) with the horizon color in the middle of the bar. You can change the color for any
angle by placing the mark near the bar and setting the color in the Color Control circle. The color for the
angles between the marks is changing gradually (interpolated).

Sky angle marks area (on the left from the Color distribution bar)

* Click anywhere in this area to place an angle mark for the sky sphere color near the Color
distribution bar. The top of the bar corresponds to the zenith (straight up camera viewing
direction), the middle point of the bar - to the horizontal viewing direction and the bottom of the bar
- to the nadir (straight down viewing direction).

* Set the color value in the Color Control circle. The color for the angles between the marks is
changing gradually (interpolated).
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After you have specified the angle mark, you can change the angle value by dragging the mark up and
down over the angle marks area. To remove a mark, drag it outside the angle marks area. Click the
angle mark to make it active. Active angle mark is displayed as depressed.

Ground angle marks area

* Click anywhere in this area to place an angle mark for the ground semi-sphere color near the Color
distribution bar. The middle of the bar corresponds to the horizontal viewing direction and the
bottom of the bar - to the nadir (straight down viewing direction).

* Set the color value in the Color Control circle. The color for the angles between the marks is
changing gradually (interpolated).

After you have specified the angle mark, you can change the angle value by dragging the mark up and
down over angle marks area. To remove a mark, drag it outside the slider control. You can not set the
ground angle value over the horizon. Click the angle mark to make it active. Active angle mark is
displayed as depressed.

Color Control circle. Click anywhere in this circle to set the color value for the current active angle
mark. Luminosity and RGB values of the color are shown near the Luminosity and RGB slider controls.

Luminosity control slider. Use this slider control to set the luminosity of the color. The changes in
luminosity are reflected in the Color control area.

RGB slider controls. Use these control sliders to set the RGB values for the color. The numeric values
are displayed to the right of each slider control. Color settings are shown by a cross mark in the Color
control area above the sliders.

Set as default for a new scene. If this item is marked the background scheme you have specified will
always be used when you start editing a new scene. Remove mark if want to use the background
scheme only for the scene you are currently editing.

OK button. Click this button to apply the background settings to the Scene and close the dialog box.

Cancel button. Click this button to cancel all editing operations and close the dialog box.

Apply button. Click this button to apply editing operations without closing the dialog box.

Related topics:

Scene background schemes: overview
Editing Background colors
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Editing Background colors

Background color is used to paint the scene background with colors to simulate the sky and the ground
colors. Background color is a part of Scene Background scheme, containing also Background Textures
and Landscape components . You can use the background from any background scheme or edit the
background colors by yourself and save new settings as a new scheme.

To start choosing or editing the Background Colors:

* Choose Set Background command on the File menu. A dialog box for setting the Scene
background properties appears.

To choose the Background Color from a scheme:

Click the drop down button to open the list of available Background

schemes.

2 Click the name of the scheme you like to use in your Scene.

3 Place a mark in the Colors checkbox and remove a mark in the Textures checkbox to make the
current scheme Background Color visible in the preview window below.

4 Preview the Background Colors arrangement by changing the camera viewing direction while
dragging the image in the preview window up and down to turn the camera vertically. You can use
the slider to the right of the preview window to control the camera orientation. The top slider
position corresponds to the Zenith (straight up) viewing direction, while the bottom slider position
corresponds to the Nadir (straight down) viewing direction. The middle slider position corresponds
to horizontal camera orientation.

5 Click the Apply button to apply the settings to the Scene you are editing.

To edit the Background Colors arrangement:
1 Choose the Background Color from any available scheme to use it as a starting point for editing.
2 Place or remove marks in the Sky Color and Ground Color checkboxes to enable or disable the
corresponding Background Color settings.

3 To set the sky color for some angle:
* Make sure the Sky Color checkbox is marked.

* Click anywhere in the area to the left from the Color distribution bar. A mark appears, which
corresponds to some angle value. The mark becomes active which is indicated by displaying
it as depressed. You can move the mark up and done by dragging it with the mouse. You can
activate existing mark by clicking it with your mouse.

» Specify the color for the active mark in the color selection circle. For this, click the point with
desired color within the circle. You can also adjust the RGB and Luminosity values manually
while moving the corresponding slider controls.

4 To set the Ground Color:
* Make sure the Ground Color checkbox is marked.

* Click anywhere in the area to the Right from the Color distribution bar. Note, that you can
specify an angle mark for the Ground color only for the angles below the horizon.

» Specify the color for the active angle mark in the way, similar to the Sky color settings. Note,
that when the Ground color is enabled, the colors for the directions below the horizon are
following the Ground color setting, which is shown both in the Color Distribution bar and the
Preview window.

5 Rearrange existing angle marks and set their colors to create the desired Background color for
your Scene. You can remove the marks you have created accidentally or those you do not need by
dragging the marks outside from the angle marks area. View the Background color arrangement in
the preview window.

6 After you finished editing the color arrangement you can apply settings to your Scene by clicking
the Apply button.

You can save the Background color setting together with Textures and landscape as a new Background
scheme in a file. You can load this scheme later and use it with any other scenes.

To save the Background scheme:
* Click Save As button and specify a filename in the standard File Save dialog box.

29



Basic Operations

Using Colors and Textures

Setting the Face Material properties: overview

Each face created in the scene may have material properties. In ISB you can set the following material
properties of a face:

* Color. You can specify any color for any face in the scene. The whole face becomes colored. The
actual face color displayed in the Perspective View window depends on the face orientation
relative to the scene light source. Thus some faces having the same color may appear lighter or
darker. You can not set the light source parameters in ISB.

* Texture. You can apply an image pattern to any face in the scene. The whole face is textured
(decorated) with the texture image. The image patterns are repeated (tiled) along the face. Thus if
you apply a single small brick image to the face, the whole face is looking like a brick wall. The
face color is hidden under a texture image.

* Transparency. You can set transparency value of a face. For example, if you set 50%
transparency to a face, it becomes semi-transparent and you can see both its material and the
items behind the face in the Perspective View window. Setting the transparency value to 100%
makes the face invisible. By specifying the face transparency you can imitate the glass material for
windows and similar scene items.

* Texture mapping. While making the face imitating the brick wall you may need to change the
period of brick images repetition along the wall to make the whole face fitting the integer numbers
of bricks along both horizontal and vertical directions. You may also want to turn or shift the texture
image pattern applied to the specific face to make it better fitting the face borders and orientation.
These operations as well as some more complex texture transformations are similar to drawing the
Earth map on the Globe.

* Texture animation. You can specify texture motion along any face in the scene and set the
motion speed and direction in ISB. Animated (moving ) textures are useful if you, for example,
want to show the water motion in a river or lake as well as moving clouds in the sky.

Every new face, created in the scene as a result of editing operations with shapes has material
properties shown in the Material Preview window , located by default at the bottom left corner of the ISB
screen in the Screen_Layout .

When you start ISB the following default material is used:

e Color - 50% gray.
* Texture - none.
e Transparency - zero. The face is not transparent.

* Texture mapping - default tiling values, specified in the Tools/Options/Texture Mapping dialog will
be used when you apply a texture to a face, created earlier without a texture. Texture image is
applied non distorted, except its size along the vertical and horizontal texture image directions.

* Texture animation - none. When you apply a texture to a face, created earlier without a texture,
the texture image does not move along the face.

Using face materials

The following options are supported:

* The face material is automatically applied to all faces in the scene, created as a result of scene
editing operations with shapes.

* The material any face a scene item can be changed anytime.
* Material properties can be spread from one face to others.

The textures for the face material are selected from the Texture gallery, the colors are selected from the
Material bar.
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To display the Texture gallery:

* Place a mark near the Textures item on the View menu.

To display the Material bar:

* Double-click the Material Preview window to open the Material bar.

To specify a texture of the material:

* Drag the texture onto the Material Preview window at the top of the Material bar.
To set a color of the material:

* Click the color you like in the Color control circle and then drag the Luminosity slider to set the
luminosity value of the color.

To set transparency value for the material:
* Drag the Transparency slider, located to the right from the Luminosity slider.
To reset all material parameters to default values:

* Right-click the Material Preview window and choose Reset on the pop-up menu.

TIP:

To learn how to use colors and textures, read “Decorating the scene” example in the ISB's Quick
Start Guide document.

Applying default material to faces

When you add a new shape to the scene, the current material from the Material bar is automatically
applied to all new faces. If a shape was added to a scene, the material is applied to the faces that are
not absorbed by other shapes in the scene. When a shape is extracted, all new faces formed as a result
of withdrawing a portion of the scene have the material properties specified in the Material bar.

Material Bar

Current material properties are displayed in this window on a sample sphere.
You can open the Material bar in full size by Double-clicking the Material Preview window.

Go to Face. Moves the camera to the position suitable for viewing the face in full size in the Perspective
View window.

Clear Texture. Removes the texture together with its mapping information from the current set of
material properties in the Material bar.

Stop texture. Stops the texture animation for the current material in the Material bar.
Material Preview window. You can preview the face material on the sample sphere in this window.

Luminosity control slider. Use this slider control to set the luminosity of the color. The changes in
luminosity are reflected in the Color control area.

Transparency control slider. Defines the transparency value of the current material.

Color Cells. Shows the basic colors available.
To define a custom color, Double-click the color cell to open Color dialog box.

Moving Texture. This is the texture animation control of the Material bar. It is used to create moving
textures.
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To animate the current texture:

1 Drag the central green circle in the direction of the texture motion.

2 The red arm of the animation control is displayed. A longer arm means faster motion. The direction
of the texture motion is defined with arm direction.

To stop animation:

. Iﬁl Click the Stop button on the toolbar at the top of the Material bar.

Go to Face
Clear Texture

Stop Texture
Material Preview

Color Sliders

Color Circle

Luminosity slider

Transparency slider

—— Color Cells

+—=———Moving Texture

Apply textures

You can apply the texture from the Texture gallery to any face in the scene.
To texture a face:

1 Look for the texture you want in the Texture gallery. To open another texture category, click its tab
on the tab strip of the Texture gallery window.

2 Drag the texture to the face in the Perspective View window.

To texture all faces of the object simultaneously:

1 Look for the texture you want in the Texture gallery. To open another texture category, click its tab
on the tab strip of the Texture gallery window.

2 Drag the texture to the Material Preview window.

3 @l Click Fill on the Brush toolbar.

4 f@ Move the pointer into the Perspective View window. It looks like a pail.
5 To texture only one face, click the face in the Perspective View window. The face is textured.
6 To texture the whole object Double-click any of its faces. The current texture from the Material bar
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will be applied to all the faces of a frozen part of the object (scene) to which this face belongs.

Notes:

* Fill and Spread operations always apply all material properties to the face. Thus texture mapping
informaton, face color under the texture, transparency value, and texture animation are also
applied to the face.

* Using the Fill and Spread operation, a face material can be spread without skipping over the blank
space or volume the part itself occupies. If there is a closed cavity inside a figure (the inner part of
it is cut out), its external and internal faces are filled by material independently.

* By Double-clicking a face, a face material is applied to all the faces of the frozen part of the scene
or current object. All other objects including its sub-objects are not changed. For example, if there
are two separate objects in a scene, the material will only be applied to the faces of the double-
clicked object.

* If two isolated parts in a scene (object) are visually interconnected with a part belonging to another
object, they are not considered interconnected in the sense of face material transfers.

Setting face colors

To set a default face color under the texture:

1 Make sure that the Material bar is displayed.
2 Click the color you like in the Color control circle and then drag the Luminosity slider to set the
luminosity value of the color.

The color you have specified will be applied as a component of material properties to all new faces
created in the scene as a result of operations with shapes.

To color one or all faces of the object simultaneously:
1 Make sure that the texture is not specified in the Material bar.

2 @l Click Fill on the Brush toolbar.
3 Click the color you like in the Color control circle and then drag the Luminosity slider to set the
luminosity value of the color.

4 e Move the pointer into the Perspective View window. It looks like a pail.

5 To color one face, click it in the Perspective View window. The face acquires the current color from
the Material bar. To color all the faces of frozen part of the scene (object), Double-click any of its
faces. All the faces of the frozen part of the object (scene), to which this face belongs, will acquire

the current color.

Note:
When an object is painted, all other objects including its sub-objects are not changed.

Spreading materials

To spread a face material properties from one face to the others:

1 gl Click the Spread button on the Brush toolbar.

2 H Position the pointer over the face with the required material properties in the Perspective View
window. The pointer looks like a brush.

3 Hold the left mouse button.
4 Drag the material through all faces to be applied.

To spread a texture or color over the whole object:

1 gl Click Spread on the Brush toolbar.
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2 H Position the pointer over the face with the required texture or color in the Perspective View
window. The pointer looks like a brush.
3 Double-click the face - all other faces of the object are textured or colored.

Notes:
* Transfer of material from a face of one object to the faces of other objects is impossible.

* Material transfer across parts, from one face to another, is impossible if there is any empty space,
even if the two parts belong to the same object (scene).

* Using the Fill and Spread operation, a face material can be spread without skipping over the blank
space or volume the part itself occupies. If there is a closed cavity inside a figure (the inner part of
it is cut out), its external and internal faces are filled by material independently.

* By Double-clicking a face, a face material is applied to all the faces of the frozen part of the scene
or current object. All other objects including its sub-objects are not changed. For example, if there
are two separate objects in a scene, the material will only be applied to the faces of the double-
clicked object.

* |If two isolated parts in a scene (object) are visually interconnected with a part belonging to another
object, they are not considered interconnected in the sense of face material transfers.

Using Pictures and Movies

Set pictures/movies onto a face

To set a picture/movie onto a face:

1 Look for the picture/movie in the Picture/Movie gallery.
+

2 n’ﬂ"""ﬂ Drag the picture/movie to the face. The pointer looks like a picture/movie with name
and an arrow.

Note:
Pictures and movies are not shown on the scene plan.
Specify movies play order
Each movie can be played forward, backward or in turn: forward - backward, forward - backward, etc.

To specify the movie play order:
N

Position the pointer over the movie you want in the Perspective View window. The pointer
looks like a picture with an arrow.

2 Right-click the movie. A pop-up menu appears.

3 Click Play order. A pop-up menu with available modes of play appears.

4 Click Forward to play the movie in the forward direction, click Backward to play the movie in the
backward direction, click Ping Pong to play in turn.

1

Copy pictures/movies

You can have several copies of picture/movie in a scene. You can make a copy using the Picture/Movie
gallery or by using the Scene Tree window.
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To copy a picture/movie using the Picture/Movie gallery:
e Putitinto the scene once more.

To copy a picture/movie using the Scene Tree window:

1 Look for the picture/movie name in the Scene Tree window.
+

2 EA""E Drag the name to the Perspective View window while holding down the Ctrl key.
The pointer looks like an arrow with a small picture near it when been dragged over the scene
parts where the picture can be placed.

Change pictures/movies location

You can change a picture/movie location in a scene by dragging it through the Perspective View window
or by dragging its name from the Scene Tree window.
To change a picture/movie location using the Perspective View window:

1 ﬂ Position the pointer over the picture/movie in the Perspective View window. The pointer looks
like a hand.

2 Drag the picture/movie in the direction desired.

To rotate the picture/movie on the face:

1 %=l Position the pointer over the picture/movie corner in the Perspective View window, holding
down the CTRL key. The pointer looks like circle with two arrows.

2 Drag the corner to rotate the picture or movie

To change a picture/movie location using the Scene Tree window:
1 Look for the picture/movie name in the Scene Tree window.
2 .A"" Drag the name to the desired location in the Perspective View window. The pointer

appears like an arrow with a small picture near it when being dragged over the scene parts where
the picture can be placed.

Resize pictures/movies

To resize a picture/movie:

1 Position the pointer over the corner of the picture/movie in the Perspective View window. The
pointer looks like a double arrow.

2 Drag the corner of the picture/movie to achieve the desired size.

Delete pictures/movies

To delete a picture/movie:
B>

Position the pointer over the picture/movie in the Perspective View window. The pointer
looks like a picture with an arrow.

2 Right-click the picture/movie. A pop-up menu appears.
3 Click Delete. The picture/movie is deleted.

1
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Advanced Features

Using Objects

Use objects

You can take a ready object from the Object gallery or construct your own object entering the Object
editing mode. You can also import objects made with Autodesk 3D Studio (see “Import objects”).

The Scene Tree

The Scene Tree presents the information about a scene structure. The Scene Tree is very similar to a
genealogical tree. The Scene Tree root node represents a whole scene. Each tree node represents an
object, picture or movie. Each node can have any number of child nodes (sub-objects). Each node, with
the exception of the root node, has a parent.

The relations between ISB objects are defined in the following way:

* When an object is resized or moved (rotated), all its sub-objects are resized by the same
coefficient or moved (rotated) by the same distance (angle).

* If an object is saved to a file or deleted, all its sub-objects are saved or deleted too.

* If the above mentioned operations are applied to a sub-object, they in no way affect its parent
object(s).

* Editing (adding and extracting shapes) a frozen part of any object does not affect any other
objects.

* Mutual subordination of the objects in a scene can be arbitrarily changed.

Notes:

* The scene is your world, and like the real world we can’t move, resize, or turn it. This means that
there are no Object Manipulators for the scene, and that you may not change its heights using the
Ruler. You also cannot apply the Cut, Copy, and Delete operations to the whole scene.

* Pictures and movies appear in the Scene Tree under their gallery names.

Place Obijects into the scene

To place an object from the Object gallery to scene:

1 Click a tab in the Object gallery, then scroll the gallery to find the object you need. Repeat this step
with other tabs till the object is found.

%*.‘

2~ lZ Castle Drag the object to the scene with the mouse.

Note:
You can drag and drop objects into the Plan, Perspective View and Scene Tree windows:

Plan window. The object becomes a child of the current object. It is located in the place where you
dropped it. The center of the parallelepiped which defines the object’s limits is set on the plan at a
point where the mouse button was released while dragging. The third coordinate of the
parallelepiped center is, by default, set in the middle of the window of the other view.

Perspective View window. An object cannot be inserted into the vacant space of a scene. The
object becomes a child of the object associated with the face upon which you drop the object. The
object attaches to the face with its own bottom face. This guarantees, for example, that when a
chair is placed on the floor, it is directly on the floor, not suspended above it or passing through it.
Scene Tree window. The object becomes a child of the object upon which it was dropped. The
center of the parallelepiped, which defines the object’s limits, is set at the origin of the scene
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coordinate system.

Objects placed according to the above methods are eligible for all object operations, such as rotation,
resizing, linking URLs, renaming ,etc.

Note:

* Obiject files in the gallery store information about the object’s orientation, including the direction of
the vertical axis of its coordinates. An object in the gallery is displayed so that its orientation
coincides with the orientation it will have when placed into a scene. When dragging an object to a
face in the Perspective View window, the object "falls" such that its vertical axis coincides with the
target face's normal. Therefore, an object such as a chair oriented in the gallery with its legs
downward is always placed on a face with its legs directly touching the face. If an object is turned
on its side in the Object Editing mode and then saved to the gallery, it will “lie on its side when
placed on the face. Our advice is to keep track of the object orientation before saving it in the
gallery, if the notions “top and “bottom make any sense (for example, objects like furniture).

Working with the Geometry Clipboard Content

You can view and edit the Geometry Clipboard content as if it is an object. ISB allows to show the
Geometry Clipboard content in a special Clipboard Content window. By default, the Clipboard Content
window is shown in the bottom right part of the ISB screen in AutoShow mode. In this mode the
Clipboard Content window is shown only if the Clipboard is not empty. If you close the Clipboard
Content window it will be shown again if the Clipboard content is changed.

To show or hide the Clipboard Content window:
* Place a mark or remove mark near the Clipboard item on the View menu.
To enable or disable the AutoShow mode:

* Right-click the Clipboard Content window to open the pop-up menu. Place a mark or remove mark
near the Enable AutoShow item to enable or disable AutoShow mode.

To save the Clipboard content as an object into the Object gallery:

* Choose Save command on the Clipboard Content window pop-up menu. Specify the name of new
object and gallery category in the Save Object dialog box.

You can enable or disable clearing of the Clipboard Content immediately, after the next Paste command
or when you load new scene:

* Choose Clear Now command on the Clipboard Content window pop-up menu to clear the
Clipboard Content immediately

* Place a mark or remove a mark near the Clear After Paste item to enable or disable clearing of the
Clipboard Content after the first Paste command. Clearing the Clipboard after the Paste command
may help to reduce the memory requirements and improve the ISB performance if you do not need
to keep the Clipboard Content after you have done the Paste command for a very complex object
placed onto the clipboard before.

* Place a mark or remove a mark near the Clear on Scene Reload item to enable or disable clearing
the Clipboard Content when you load a new scene in ISB. Keeping the Clipboard content while
loading another scene is useful for insertion of the Clipboard Content as an object from one scene
to another.

You can edit the Clipboard Content as an object in the Object editing mode. To edit the Clipboard
Content do one of the following:

* Choose Edit on the Clipboard Content window pop-up menu or
* Double-click the Clipboard Content window.
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The Clipboard content is opened in the Object editing mode. After you have finished editing click Scene
Plan tab. The object you have created is placed onto the Clipboard.

To insert the Clipboard Content into the scene as a new object:

* Choose Paste command on the Edit menu or
¢ Click the Paste button on the Standard toolbar or

* Drag the object from the Clipboard Content window on the Plan window or onto any face in the
Perspective View window. This operation is completely equivalent to the Drag and Drop operation
for the object from the Object gallery.

Import objects

To import an object from a file in the 3D Studio format and save it into the Object gallery, do the
following:

1 Choose Import on the Object menu. The standard dialog box for file specification appears.

2 In the Save Object dialog box, enter a name which will accompany the object in the Object gallery,
and the category to which the imported object will be saved. The data in the 3DS format are
converted to the ISB format and are written as an object to the Object gallery. After an object is
created, it can be edited using standard ISB commands.

Note:
An imported object can include sub-objects.

Manipulating Objects

Select objects

To manipulate an object you should select it in the Perspective View, in the Scene Tree, or in the Plan
window.

Note:
Pictures and movies can be selected only in the Scene Tree window.

To select an object in the Perspective View window:

Click the object. The selected object is marked with a yellow bounding box.

To select an object in the Scene Tree window:

* Click the object’'s name. The name of the selected object is highlighted.

To select an object in the Plan window

1 Move the pointer into the Plan window and point to the edge of the object you want to select in the
Plan window. The pointer should look like an arrow with a house near it.

2 @ Double-click one of the visible edges of an object. Both views are shown in red.

The selected object is displayed in the following manner:

In the Perspective View window the object is marked by a yellow bounding
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i The Scene

In the Scene Tree window the object’s name is highlighted.

. O

. In the Plan window the object’s views are red. Its sub-objects appear
in magenta.

Note:

When the whole scene is selected there is no yellow bounding box in the Perspective View
window. All scene objects are indicated by the color magenta in the Plan window.

Create objects

To create a new object which is a sub-object of the current object in the scene:

1 il Choose New from the Object menu or click New Object on the Edit toolbar. The Object

editing mode is entered. The Scene Tree window displays a new node with the name assigned by
default.

2 Construct an object using shapes. All operations described in the “Construct scene” chapter are
valid for objects too.

3 Choose Back to Scene from the Object menu or click Object Edit on the Edit toolbar to release it.
The Save Obiject dialog box appears.

4 In the Save Object dialog box, choose the desired saving mode:
* Click Scene to place the object directly into the scene at the origin of its coordinates.
* Click Clipboard to place a new object into the clipboard for later insertion into a scene.

* Click Object Gallery to save a new object in the gallery. In the Name field, define the name which
will accompany object in the Object gallery. In the field Category, define the name of the gallery
category where the object is to be included.

* Click Yes to save the object, click No to return to the Scene Assembling mode without saving the
object, or click Cancel to return to the Object editing mode.

Note:

If you place a newly created object into the clipboard, you can later insert the object into any part of
a scene, at any level of its hierarchical structure.

Saving current object

To save the current object:

1 Click Save on the Object menu. The dialog box appears.
2 In the field Name, define the name under which the object will be displayed in the Object gallery.

3 In the field Category, define the name of the category where the object is to be included.
4 Click OK.

To save an object in the current Object Gallery:

* Drag the name of the object from the Scene Tree window to the Object gallery. The object is
copied into the specified gallery.
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TIP:

Object files in the gallery store information about the object’s orientation, including the direction of
the vertical axis of its coordinates. An object in the gallery is displayed so that its orientation
coincides with that it will have when placed into a scene. While dragging an object to a face in the
Perspective View window, the object "falls" such that its vertical axis coincides with the target
face's normal. Therefore, an object such as a chair oriented in the gallery with its legs downward
is always placed on a scene face with its legs on. If an object is turned on its side in the Object
Editing mode and saved in the gallery, then subsequently added to a scene, it will also "lie" on its
side on the scene face. Our advice is to keep track of the object orientation before saving it in the
gallery, if the notions “top and “bottom make any sense (for example, objects like furniture).

Deleting objects

To delete an object:

1 Select the object (see “Select objects” for details) to be deleted.
2 Choose Delete on the Edit menu or press Del key.

Renaming objects

To rename an object:

1 Right-click the object name in the Scene Tree window. When the pop-up window appears choose
Rename. You may also click the object name in the Scene Tree window. An edit box for the object
name appears.

2 Enter the new name and press Enter.

Get object info

To get information about an object:

1 Right-click the object in the Scene Tree window.
2 Choose Info in the pop-up menu. The window describing the object appears.

Move and copy objects into another place in scene

To transfer an object to another scene place:

1 Click the object name in the Scene Tree.

2 Drag the object icon to any face of a scene in the Perspective View window. The object is placed
as if the face is holding it up. For example, when an object such as a chair is dragged to the
vertical face of a scene, the chair is placed with its legs directly in contact with this face, as if the
face was the ground.

To copy an object to another scene place:

1 Click the object name in the Scene Tree window.

2 Drag the object icon to any face of a scene in the Perspective View window while holding down the
Ctrl key. The object is copied as if the face is holding it up. For example, when an object such as a
chair is dragged to the vertical face of a scene, the chair is placed with its legs directly in contact
with this face, as if the face was the ground

Notes:

* An object cannot be moved or copied to a vacant space in a scene, to its own face, or to a face of
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its sub-object by the above method.
* If an object is moved or copied to a face of another object, it becomes its sub-object and is placed
on directly on the other’s face.

* When an object is moved or copied, all its sub-objects are also moved or copied, retaining their
orientation relative to the parent object.

Move and copy objects into another hierarchy level

To move an object:

* Drag its name to the name of the object you want to make a parent - drag until the parent’s name
becomes highlighted in the Scene Tree window.

Fitting windows to objects

To make object views visible in the Plan window:

. EI Click Fit to Object on the Plan toolbar.

Notes:

* If only one view is open when you choose the Fit to Object command, the scale of the plan is
adjusted specifically to this window. The plan of the object may not fit into the window of the other
view when it is opened.

* Objects on the plan have the dimensions of a rectangular parallelepiped, where the object and its
sub-objects, together with cameras, are included. The scale of the plan is adjusted so that all
components of the object are visible.

* This command is executed automatically when you enter the Object Editing mode.

Editing Objects

Edit objects

You can edit objects in the Scene Assembling and Object Editing modes.

It is convenient to edit an object in the Scene Assembling mode if you want to adjust its size or
orientation relative to the other components in the scene. For example, you would use this mode to
make two tables of the same height. You can also edit objects using shape operations. The edited
object is not saved automatically in the Object gallery. You must save it by yourself using the procedure
described in the “Saving current object” section.

Note:

If an object is saved to the gallery after it is edited in the Scene Assembling mode, only the results
of operations with shapes and painting/texturing are saved. The changes in size, proportion or
object orientation which were made directly in the scene or while editing its parent object are not

saved.
The Object Editing mode allows you to create a hew object or completely modify the existing one. The

object is automatically saved in the Object gallery or placed into the scene or clipboard. All modifications
including rotation, scaling and skewing are saved.
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Changing size, position and orientation using Object Manipulator

Object position, orientation, size and proportions are set with the Object Manipulator. It is turned on
while selecting an object in the following way:

1 Position the pointer in the Plan window. If positioned on any line on the scene plan the form of the

mouse pointer changes to an arrow with a house icon and displays the object name associated
with this line.

2 @ Double-click a plan’s line associated with the desired object. The object becomes selected
and the Object Manipulator appears nearby.

To change an object s position:
. %) Drag the Object Manipulator's moving point (it's center). The moving point coordinates
are seen on the status bar as the pointer is in motion. You can move an object in any of the three

virtual space dimensions using the top view window for horizontal movements, and the front view
window for moving vertically and along one of the horizontal axes.

To change an object ’s size:

o f Drag the Object Manipulator’s resize jack (the boxes at the end of the object axes or
“levers). Coordinates of the center of the Object Manipulator and object’s size in the direction of
change are displayed on the status bar.

To change an object 's orientation:

o <—/T Drag the Object Manipulator’s lever. To rotate the box in the horizontal plane, rotate in the
top view. To rotate (incline) the box in the vertical plane, rotate in the front view.

To skew an object:

* Drag the Object Manipulator’'s moving point while holding down the Shift key. If the moving point is
relocated while holding down the Shift button, skewing of the object occurs: its center shifts while
the bottom face remains stationary. The face that was initially the lowest upon addition to a scene
always remains stationary under deformations, irrespective of any object rotations.

To achieve smooth object rotation:
* Hold down the Ctrl key while dragging a lever.
To resize an object in all dimensions at once:

* Press Gray + key on the numeric key pad to enlarge the object or the Gray - key to shrink the
object.

Related topic:

Set shape position, size, and orientation.
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Changing object’s height using the Ruler

Two Rulers can be displayed in the Ruler window:

* The gray Ruler corresponds to the current shape, included into the scene. Use the gray Ruler to
change the shape’s height.

* The red Ruler corresponds to the current scene object (previously added to the scene). Use the
red Ruler to change the height of the current object.

The top lath (the gray box on the top end) of the red Ruler defines the position of the top face of the
current object’'s bounding box. The bottom lath of the red Ruler defines the position of the bottom face of
the current object’s bounding box.

To move the Ruler’s laths:

. @ Position the pointer over the lath. The pointer looks like an arrow and a house.
* Drag the lath up or down.

Note:

If the current object is the entire scene, the red Ruler corresponds to the upper and lower limits of
a parallelepiped, which includes all scene parts and all objects. Height resizing operations,
however, are unavailable when the entire scene is currently selected.

Add and extract shapes

1 Select the object you want to edit.

2 Include a draft shape (see “Include ready shape into a scene”) into the scene, set its position, size
and orientation with respect to the shape or object it will affect.

3 Apply shape using the Add, Extract, Copy, Cut or Delete operations. They are described in detail in
the Apply shapes to scene section.

Notes:

* During shape operations only the frozen part of the edited object is changed - all other objects (as
well as the scene) do not change.

* To keep the shape you have included into the scene present on the scene plan after you have
applied it to the scene, hold down the SHIFT key while clicking the Add, Extract, Cut or Copy
commands. You can apply the same shape once more next time.

Cut, copy, and paste objects and their parts

You can cut or copy an object or part of an object onto the clipboard and paste it into another place in
your scene. You define an object part for cutting or copying using a shape.

To cut or copy the whole of the object onto the clipboard:
1 Select the object you want to edit.

2 il Click the Cut button on the Standard toolbar or choose Cut on the Edit menu to cut the

object to the clipboard. Click the Copy button on the Standard toolbar or choose Copy from
the Edit menu to copy the object to the clipboard. The object and all its sub-objects are copied onto
the clipboard.

To cut or copy part of the object to the clipboard:
1 Select an object you want to edit.
2 Include a draft shape (see “Include ready shape into a scene”) into the scene or create a shape on
the fly. Set the shape’s position, size and orientation so that it contains some part of the edited
object.
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3 il Click Cut on the Standard toolbar or choose Cut on the Edit menu to cut part of the original

object and parts of its sub-objects, inside the shape onto the clipboard. Click Copy on the
Standard toolbar or choose Copy on the Edit menu to copy part of the object and parts of its sub-
objects, inside the shape onto the clipboard. To make Cut or Copy commands effective only to the
current object, but not its sub-objects, hold down CTRL key while clicking the Cut or Copy buttons.

To paste data from the clipboard, do one of the following:
. Igl Click Paste on the Standard toolbar or choose Paste on the Edit menu to paste data from
the clipboard to the scene’s origin coordinates.

* Right-click the place in the Perspective View or Plan window where you want to paste data. The
pop-up menu appears. Click Paste.

An object will be inserted into a scene so that the center of the parallelepiped which defines its limits will
appear at the click point on the plan.

Notes:

* When you paste data from clipboard, the resulting object is always a sub-object of the currently
selected object or scene. Be sure to select the desired parent object before doing the Paste
operation.

* If you paste data that has been previously cut or copied from a scene into a scene, the result is a
new independent object in the scene.

TIPS:

* To transform a part of a scene into an object, you may cut this part using the Cut or Copy
operation and then insert it into a scene from the clipboard.

* To keep the shape you have included into the scene present on the scene plan after you have
applied it to the scene, hold down the SHIFT key while clicking the Add, Extract, Cut or Copy
commands. You can apply the same shape once more next time.

Manipulating Objects in the Perspective View Window

Manipulating objects in the Perspective View window

You can change the object’s position, scale and orientation directly in the Perspective View window with
the help of Object manipulator displayed in this window. This is useful when:

* You need to position and set the size of the object in 3D space relative to the other scene items
and view the result directly in the Perspective View window.

* You need to place the object onto the specific face of the other scene item, for example on the
ground landscape surface or on the floor of the virtual house.

To display the Object manipulator in the Perspective View window:

1 Select the object you want to manipulate in the Perspective View window.

2 Selected object is displayed with yellow frame parallelepiped around it, designating the object’s
bounding box position and orientation.

3 Choose Manipulate Object command on the Object menu to display the Object manipulator
controls on the bounding box frame edges and vertexes.

Using the Object manipulator controls in the Perspective View window you can:

* Rotate the object.
e Scale the object in all dimensions at once.
* Move the object to another place and snap it onto another face in the scene.
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Object manipulator controls in the Perspective View window

The Object manipulator controls in the Perspective View window are shown on the picture. There are
three types of controls:

X
S

Object rotation controls: yellow boxes in the middle points of each edge of the object bounding box.
When you position the mouse pointer over the rotation control a tool tip with the name of the operation
and object’s name appears on the screen.

e |5cale Chair

Object resizing (scale) controls: yellow boxes in each bound box vertex. When you position the mouse
pointer over the scale control a tool tip with the name of the operation and object's name appears on the
screen.

[Snap Chair to Face|
Object snapping/displacement control. This control is located in the middle of the bottom face of the

object’s bounding box. If the object is placed onto the face this control may be hidden. To make it visible
you have to rotate the object around the axis, parallel to its bottom face first.

Rotating the object directly in the Perspective View window

asf
el

You can rotate the object in the Perspective View window using the rotation controls: yellow boxes in the
middle points of each edge of the object bounding box. When you position the mouse pointer over the
rotation control a tool tip with the name of the operation and object’'s name appears on the screen.

Each rotation control rotates the object around the axis going through the center of object’s bounding
box parallel to the edge on which the rotation control is located. The procedure is illustrated by a set of
pictures below:
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Rotating the object around the first chosen axis:

>>

around the next axis:

Rotating

>>

around the last available axis:

Rotating

Note:

If you rotate the object around the axis, parallel to the bottom face of its bounding box, the object
becomes not snapped to the face of the scene item. If you move it later it may turn back to snap to

the face.

Scaling the object directly in the Perspective View window

—
ke |Scale Chair

You can resize the object directly in the Perspective View window using the object scaling controls:
yellow boxes in each bound box vertex. When you position the mouse pointer over the scale control a
tool tip with the name of the operation and object’s name appears on the screen.

Following rules are applied for the scaling operations:

* The object is resized (scaled) in all dimensions at once when you drag the scaling control:
— increased, if you move the pointer out of the opposite diagonal vertex of the object bounding box
— decreased, when you move the pointer closer to the opposite diagonal vertex of the object
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bounding box.

* The opposite diagonal vertex of the object’s bounding box always keeps its location in space while
you are resizing the object. This ensures that the object does not expand into the wall or under the
ground if you scale it by dragging the opposite to the wall vertex, as shown on the pictures below:

>>

» If you scale the object while dragging its bottom vertex the object becomes intercepting the floor or
the wall. Use this technique only if you actually need to insert the object into the other scene items.

The result of scaling is illustrated on the picture below:

Try scaling the objects in the Perspective View window by yourself and find your own intuitive
understanding of the scaling procedures.

Moving the object directly in the Perspective View window

:.P

[Snap Chair to Face|

You can move the object and snap it to any visible face of the other item in the Perspective View
window using the object snapping/displacement control. This control is located in the middle of the
bottom face of the object’'s bounding box. If the object is placed onto the face this control may be
hidden. To make it visible you have to rotate the object around the axis, parallel to its bottom face first.

The steps below, illustrated by pictures explain typical procedure of moving the object in the Perspective
View window in the scene, already containing other items:

1. Select the object you want to move by clicking it in the Perspective View window. Click it once more
or choose Manipulate command on the Object menu to show the Object manipulator in the Perspective
view window. The object snapping control is hidden under the object and you have to rotate the object to
make the snapping control accessible.
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2. Rotate the object dragging its rotating control. Choose the proper rotation axis to make the bottom
face of the object’s bounding box clearly visible.

3. Position the pointer on the snapping control. A tool tip with the name of the operation and the object
appears.

4. Move the pointer to make it pointing to the horizontal face in the scene. The object becomes attached
by its bottom to that face and slides along it while you move the mouse. The snapping control is
positioned on the face exactly in the point, defined by the mouse pointer position.

5. Move the pointer to make it pointing to the vertical face in the scene. The object becomes attached by
its bottom to that face and slides along it while you move the mouse. The snapping control is positioned
on the face exactly in the point, defined by the mouse pointer position.
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You can also move the object inserted in to the empty scene with the help of the Object manipulator in
the Perspective View window. The operation is explained and illustrated below. There may be two
different cases: the object is placed into the empty space without visible faces or the object is not
attached to any face, but there is another visible item in the Perspective View window. The pictures to
the left and to the right from the text illustrate these cases.

1 Make the object snapping control accessible by setting the camera in appropriate position.

¥,

[

Snhap Bathub to Face

Snap Bthtul:u to Face

2 Now you can move the object by dragging its snapping/displacement control with the mouse in the
Perspective View window. The object is moving along the plane to which belongs the bottom face
of its bounding box. For the object orientation shown on the picture:

* Moving the mouse pointer up in the Perspective View window results in shifting the object up and
closer to the camera.

* Moving the pointer down in the Perspective View window results in shifting the object down and
back from the camera.
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Moving the pointer to the right results in shifting the object in the empty space along the horizontal
(as it is displayed for the current object in the Perspective View window) edge of its bounding box
or in snapping the object to the face of the item, located behind the object. Because the distance
between the camera and the box behind the object is bigger than to the object, the object jumps in
space to become attached to the face which you have pointed by the mouse.

If you continue moving the pointer to the right the object snaps to the other face of the box.
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Using VRML Geometry Primitives

VRML primitives: overview

The three dimensional items in the scene are usually treated in ISB as sets of faces. For example, if you
create an object by adding the shape Cone56 to the new empty object in the Object Editing mode (see
“Editing objects in the Object Editing mode”), the object you have created is a set of 57 faces looking
like a cone. While there is no difference for you what is actually written in the scene file, the size of the
file, describing set of faces, simulating smooth sphere, cylinder or cone may be very large.

VRML 2.0 language includes a special geometry nodes, describing the primitive objects Box, Cone,
Cylinder and Sphere which description in the file contains only the corresponding keyword and several
numbers describing the primitive dimension. Using these primitives you can significantly reduce the size
of scene file. The following rules are applied to the VRML primitive objects in ISB, reflecting the VRML
language specifications:

* Because each VRML primitive object has only limited number of parameters there are some
limitations on their re-sizing and rotating while you are editing them in the Object Editing mode.
The corresponding limitations are described in the Help topics about each primitive. In the Object
Editing mode the limitation are reflected by the absence of the Object Manipulator control,
responsible for the prohibited action.

* Because the primitives are not face sets, ISB can not preserve the object description as a keyword
with few parameters if you apply the shape to VRML primitive object, overlapping in space with it
the while editing. The resulting object will be converted to a set of faces.

* If you apply shape (or several shapes), separated in space from the primitive, the scene file will
contain an object description combined from an indexed faceset node and a short description of
the primitive within the same object.

* You can not combine two VRML primitives within the same object in ISB. Each VRML primitive
object is defined as a separate object. You can insert new VRML primitive object as sub-object of
the scene or any other object, including another VRML primitive.

* All VRML primitive object’s surface is treated in the VRML language specifications as a single face.
There are special rules concerning the way the texture is mapped on that face, individual to each
primitive object. That is why you can apply only single texture to the VRML primitive object as a
whole. When you drag the texture onto the object in the Perspective View window all object
surface is highlighted and the texture is placed on it following the VRML specifications. You can
perform all mapping operations for the texture on the VRML primitive object in the same manner
as for the ordinary object’s faces in ISB. The difference is that in case of VRML primitive object,
texture mapping is always applied to entire object’'s surface instead of a single face of ordinary
(faceset) object.

* If an object is composed of a VRML primitive and a set of faces, separated spatially, then you can
use the texture applying and mapping operation to a faceset part of such object in a normal for ISB
manner.

* You can resize, rotate and skew VRML primitive object in all directions only if you are in the Scene
assembling mode or while editing the VRML primitive parent object in the Object editing mode.
That is because VRML primitive must remain correctly described by its parameters in its own
coordinate system.

Box VRML primitive object

You can create a new solid box (rectangular parallelepiped) as a VRML primitive object. The object
created will become sub-object of the current object.
To create a new VRML primitive object Box:

e Choose New command on the Object menu, point to Box item on the drop-down sub-menu and
click the left mouse button.

The box created with that command follows the VRML 2.0 specifications of the geometry node Box. The
Box node specifies a box as a rectangular parallelepiped, located in the coordinate system’s origin with
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its faces oriented parallel to the coordinate system axes. In ISB VRML primitive objects are always
created as objects and the above definition is valid in the object coordinate system, or, in other words,
while you are editing the Box in the Object Editing mode (see “Editing objects in the Object Editing
mode”). However you can move, rotate, resize and skew the Box primitive object freely in the Scene
assembling mode or while editing its parent object.

While editing the Box in the Object Editing mode you can change only a Box width, depth and height
with the Object Manipulator. You can not rotate or skew a Box. The Object Manipulator for the Box
primitive does not allow rotating and skewing operations.
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The Box surface is treated as a single face. So if you apply a texture to a box entire its surface is
textured. The texture image is applied to the whole box face without tiling by default. The texture image
is applied to the front face keeping texture coordinates parallel to the box edges. The other faces of a
Box are textured in a way, keeping the texture image looking “naturally while you rotate the Box. On the
picture to the left this is illustrated by a Box, textured with the image shown above the box, which you
can read in normal direction while you rotate the Box.

Note:

While editing, if you apply a shape which intercepts with a box, the resultant object will be
transformed to an indexed faceset. Indexed faceset description takes much more size into the
scene file. You can not texture all faceset as a single face. Each time you attempt to apply a shape
which cause the transformation of the base VRML primitive node to an indexed faceset you get a
message box with a warning.

Cylinder VRML primitive object

You can create a new solid Cylinder as a VRML primitive object. The object created will become sub-
object of the current object.

To create a new VRML primitive object Cylinder:

e Choose New command on the Object menu, point to Cylinder item on the drop-down sub-menu
and click the left mouse button.

The Cylinder created with that command follows the VRML 2.0
specifications of the geometry node Cylinder. The Cylinder
node specifies a Cylinder, located in the coordinate system’s
origin with its axis oriented parallel to the vertical coordinate
system axis. In ISB VRML primitive objects are always created
as objects and the above definition is valid in the object
coordinate system, or, in other words, while you are editing the
Cylinder in the Object Editing mode. However you can move,
rotate, resize and skew the Cylinder primitive object freely in
the Scene assembling mode or while editing its parent object.
While editing the Cylinder in the Object Editing mode you can
change only a Cylinder radius and height with the Object
Manipulator. You can not make its bottom face elliptical, rotate
or skew a Cylinder. The Object Manipulator for the Cylinder
primitive does not allow rotating and skewing operations.
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The Cylinder surface is treated as a single face. So if you apply a texture to a Cylinder entire its surface
is textured. The texture image is applied to the Cylinder side surface without tiling by default. The texture
image is applied keeping vertical texture coordinate parallel to the Cylinder axis. Top and bottom faces
of a Cylinder are textured in a way, keeping the texture image looking “naturally while you rotate the
Cylinder. On the picture to the left this is illustrated by a Cylinder textured with the image shown above
the cylinder, which you can read in normal direction while you rotate the Cylinder in the scene.

Note:

While editing, if you apply a shape which intercepts with a Cylinder, the resultant object will be
transformed to an indexed faceset. Indexed faceset description takes much more size into the
scene file. You can not texture all faceset as a single face. Each time you attempt to apply a shape
which cause the transformation of the VRML primitive object to an indexed faceset you get a
message box with a warning.

Cone VRML primitive object

You can create a hew solid Cone as a VRML primitive object. The object created will become sub-object
of the current object.

To create a new VRML primitive object Cone:

* Choose New command on the Object menu, point to Cone item on the drop-down sub-menu and
click the left mouse button.

The Cone created with that command follows the VRML 2.0 specifications of the geometry node Cone.
The Cone node specifies a cone, located in the coordinate system’s origin with its vertical axis parallel to
the coordinate system vertical axis. In ISB VRML primitive objects are always created as objects and the
above definition is valid in the object coordinate system, or, in other words, while you are editing the
Cone in the Object Editing mode. However you can move, rotate, resize and skew the Cone primitive
object freely in the Scene assembling mode or while editing its parent object.

While editing the Cone in the Object Editing mode you can change only a Cone bottom face radius and
height with the Object Manipulator. You can not make its bottom face elliptical, rotate or skew a Cone.
The Object Manipulator for the Cone primitive does not allow rotating and skewing operations.

The Cone surface is treated as a single face. So if you apply a
texture to a Cone entire its surface is textured. The texture
image is applied to the whole Cone side surface and its bottom
face without tiling by default. When a texture is applied to the
sides of the cone, the texture wraps counterclockwise (from
above) starting at the back of the cone. The texture has a
vertical seam at the back of the Cone. The other faces of a
Cone are textured in a way, keeping the texture image looking
“naturally while you rotate the Cone. On the picture to the left
this is illustrated by a Cone textured with the image shown
above the cone, which you can read in normal direction while
you rotate the Cone.

Note:

While editing, if you apply a shape which intercepts with a
Cone, the resultant object will be transformed to an indexed faceset. Indexed faceset description takes
much more size into the scene file. You can not texture all faceset as a single face. Each time you
attempt to apply a shape which cause the transformation of the VRML primitive object to an indexed
faceset you get a message box with a warning.
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Sphere VRML primitive object

You can create a new solid Sphere as a VRML primitive object. The object created will become sub-
object of the current object.

To create a new VRML primitive object Sphere:

* Choose New command on the Object menu, point to Sphere item on the drop-down sub-menu and
click the left mouse button.

The Sphere created with that command follows the VRML 2.0 specifications of the geometry node
Sphere. The Sphere node specifies a Sphere, located in the coordinate system’s origin. In ISB VRML
primitive objects are always created as objects and the above definition is valid in the object’s local
coordinate system, or, in other words, while you are editing the Sphere in the Object Editing mode.
However you can move, rotate, resize and skew the Sphere primitive object freely in the Scene
assembling mode or while editing its parent object. While
editing the Sphere in the Object Editing mode you can change
only a Sphere radius with the Object Manipulator. You can not
make it ellipsoidal, rotate or skew a Sphere. The Object
Manipulator for the Sphere primitive does not allow rotating and
skewing operations.

The Sphere surface is treated as a single face. So if you apply a
texture to a Sphere entire its surface is textured. When a texture
is applied to a sphere, the texture covers the entire surface,

! wrapping counterclockwise from the back of the sphere. The

. texture has a seam at the back of the Sphere. On the picture to
: the left this is illustrated by a Sphere textured with the image
shown above the sphere.

Note: While editing, if you apply a shape which intercepts with
a Sphere, the resultant object will be transformed to an indexed faceset. Indexed faceset description
takes much more size into the scene file. You can not texture all faceset as a single face. Each time
you attempt to apply a shape which cause the transformation of the VRML primitive object to an
indexed faceset you get a message box with a warning.

Using Plain Text Objects

Using Plain Text objects

You can create Plain Text object as a sub-object of the current object. The plain text object created
follows the VRML 2.0 specifications of the geometry node Text. VRML Text node defines text, displayed
as a two sided face in the scene. Plain Text object is described in the scene file with the corresponding
keyword and a text with several parameters. Compared with the 3D Text object, defined in ISB such
description takes much less space. However because the Plain Text object does not have thickness,
you can create only flat writings using this object. Following options are supported for the Plain Text
object:

* You can edit the text writing, change its font, font style, text alignment, orientation, line and
character spacing.

* Plain Text object is treated in the scene as a single face. So the texture is always applied to all
characters in the Plain Text object.

* If you apply shape while editing the Plain Text object and it intercepts in space with the Plain Text
the whole object will be converted to a set of faces. That is because ISB cannot preserve short Text
description used in VRML language in this case.

* The width of Plain Text object is defined by the length of the longest text line in the text. You can
only resize the Plain Text object in all dimensions at once. The proportion between its width and
height is defined by the font, font style and character and line spacing parameters.
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To create a new Plain Text object:

1 Choose New on the Object menu, point to Plain Text and click the left mouse button. ISB switches
into the Object Editing mode. An example of Plain Text object containing Plain Text writing is
shown in the Perspective View window. Plain Text object Format dialog box appears. In this dialog
box you can edit a text string and set its font and alignment properties.

Al Text. Enter the text in this field. The text may contain several lines. Each line is located
below the previous line for the horizontal text orientation or to the right from the previous line for
vertical text orientation. To edit the text when the Format dialog box is closed click the arrow to the
right from the Text button and edit the text in a small textbox which drops down.

3 ISE"f :Iv Font. Select a font from the list of available fonts. To select font when the Format
dialog is closed select font from the list on the Formatting toolbar

B|F . .
4 _|_| Font style. Select a font style from the list of available font styles. To select font style
when the Format dialog is closed click Bold or Italic buttons on the Formatting toolbar.

Alignment. Select the alignment type from the list. To set text alignment when
the Format dialog is closed click the corresponding button on the Formatting toolbar.

A
6 Il Orientation. Select the text lines orientation. Note, that the characters in the lines of the
Plain Text object always have vertical orientation. Orientation button on the formatting toolbar
performs the same action when the Format dialog box is closed.

7 Line spacing. Select the line spacing from the list. To set more than double line spacing set
Multiple in the Line spacing field at set the desired number in the At field.

8 Character spacing (scale). Select the value of character spacing from the list. This setting does
not affect the characters height.

9 Default button. Click this button to restore the default text formatting settings.

Click OK to apply changes, close the dialog box and view the result of formatting in the Perspective view
and Plan windows or click Cancel to cancel formatting.

*
é‘ﬂ Click Text button on the formatting toolbar or choose Format command on the Text menu to
revert to editing of text in the Plain Text object and open the Format dialog box.

To edit already existing Plain Text object:

1 Select the object containing Plain text
2 Click the Object Plan tab below the Plan window to switch to the Object editing mode.

3 If the object you are editing contains VRML primitive Text as a part Formatting toolbar appears
below the Standard toolbar of ISB screen.

4 Edit the Plain Text object using the Formatting toolbar or Format dialog box commands described
above in this topic.

Notes:

* If you have already converted the Plain Text object to an indexed face set it becomes ordinary ISB
object. Text formatting commands are no longer available for this object.

* If you have added the face set part to the Plain Text object, not intercepting with text in space you
are still allowed to format the text. The face set part of such object is resized in all dimensions as
well as Plain Text part while you are resizing the object in the Object editing mode.

Using 3D Fonts

You can include an inscription with solid characters from any True Type font in a scene as an object.
The 3D Text dialogue box is opened by the 3D Text command from the Object menu, which permits

you, in addition to text editing, to choose a font, set character color and execution quality. The picture
shows an example of using 3D fonts.
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To enter 3D text:

Choose 3D Text from the Object menu. A dialog box appears.
In the Font list box, select the desired font.

In the Font style section choose the desired style.

In the Color list box, select the color for text.

In the Script field, choose a character set available for this font.

In the Geometry section, enter the values for character height and thickness. Choose the quality
of the display in a scene.

In the Text field, enter the desired text.

8 In the Insert to box, choose Clipboard to place text object onto the clipboard, Object gallery to
place it to the Object gallery, or Scene to place it into the scene.

9 Click OK.

D O W N P

~

Notes:

* You may preview the animated (rotating) text string in the bottom window of the Add Text dialog
box. In the right bottom corner of the dialog box you can view the number of faces and vertexes of
the 3D text object. Note that complex objects having a large number of faces occupy more disk
space and memory. Consequently they may take longer to load.

* You can paste text from the clipboard into a scene using the Paste command.
* Text placed into the Object gallery becomes available for scene construction like any other object
from the Object gallery.

* Text placed into a scene becomes a sub-object of the current object. It appears at the origin of the
scene’s coordinate system.

Multimedia Capabilities

Attach sound

You may attach sound to any scene object, including pictures and movies. You may attach sound from a
file, you can record it from a microphone or from any audio source supported by your sound card.

To attach sound from a file:

1 Click the right mouse button on an object, a picture or movie in the Perspective View window, the
icon of an object, a picture or movie in the Scene Tree window.

2 Choose Attach sound on the Object menu. The Edit Sound Attachment dialog box appears.
3 Click the Browse button to specify a sound file.
4 Specify the sound file and click OK.

To record sound:

1 Click the right mouse button on an object, a picture or movie in the Perspective View window, the
icon of an object, a picture or movie in the Scene Tree window.

Choose Attach sound on the Object menu. The Edit Sound Attachment dialog box appears.
Click Record to start recording. The length of a record may not exceed 1 minute.

Click Stop when recording is finished.

Click Play to hear recording.

Repeat the writing and sound hearing operations if necessary. After the desired sound is recorded,
press OK. The standard dialog box for file specification appears.

7 Name the sound file and click OK.

o O~ W N

Notes:

* The internal sound recorder is working in 8 bit mono mode. Use the volume control program of
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your operating system to set the recording levels for all sound sources, such as microphone, line
in, midi, etc. For better sound quality prepare the sound file using specialized sound recording
software.

* In addition to the above method, sound can be attached to the current scene object through the
Attach sound command from the Object menu.
-2 objectl
4% ohject2 A scene element to which sound is attached is indicated in the Scene Tree
window with a loudspeaker icon.

* You can also add sound by using the Attach MIDI from the File menu. This attaches a MIDI file to
the current scene. It is played when the scene is loaded in the VRML browser.

Play sound

To play sound:

1 Click the right mouse button on an object, a picture or movie in the Perspective View window, the
icon of an object, a picture or movie in the Scene Tree window.

2 Choose Play sound on the Object menu. The sound attached to the object is played.

Note:

In addition to the above method, sound attached to the current scene object can be played through
the Play sound command from the Object menu.

Detach sound

To detach sound:

1 Click the right mouse button on an object, a picture or movie in the Perspective View window, the
icon of an object, a picture or movie in the Scene Tree window.

2 Choose Detach sound on the Object menu. The sound attached to the object is detached.

Notes:

* |n addition to the above method, sound attached to the current object can be detached through the
Detach sound command from the Object menu.

* The detach sound command does not erase or remove the sound file from the computer disk.

Link URLs

You can link a URL to any object, including pictures and movies.

To link URLs:

1 Click the right mouse button on an object, a picture or movie in the Perspective View window, the
icon of an object, a picture or movie in the Scene Tree window.

2 Choose Link URL on the Object menu. The Link Internet Shortcut dialog box for URL specification
appears.

3 Enter the full URL in the URL field.

4 Enter text in the Description field.

5 Click OK.

Note:

In addition to the above method, URL can be linked to the current object through the Link URL
command from the Object menu.
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Removing URLs

To remove URLs:

1 Click the right mouse button on an object, a picture or movie in the Perspective View window, the
icon of an object, a picture or movie in the Scene Tree window.

2 Choose Remove URL on the Object menu. The URL link is removed.

Note:

In addition to the above method, URL linked to the current object can be removed through the
Remove URL command from the Object menu.

Publishing Scene
Preparing the scene for publishing

To prepare a scene for publishing ISB creates a new directory in which all data describing the scene is
placed. This sub-directory will contain the scene’s .wrl file and other resource files, for example,
textures, sounds, pictures, etc. After the directory is created you may upload the scene to your Web site.

To prepare the scene for publishing:

1 Choose Publish on the File menu. The dialog box for the scene specification appears.

2 Enter the name of your scene .wrl file in the Scene name field.
3 Enter the full path name of a directory in the Location field. ISB creates a sub-directory with the
name of the scene and places all required data there.

4 Mark the checkbox “Put all resources in one folder to have all scene files in one folder. Clear the
checkbox to place resources independently, i.e. one sub-directory for the scene textures, another
sub-directory for scene pictures, etc.

5 Click OK.

Upload scene to the World Wide Web

To upload a scene to Web:

* Choose Post to Web from the File menu and then follow the instructions displayed on the screen.

Notes:

e Consult with your Internet Service Provider or Network administrator regarding how to set the
correct data in the dialogs displayed on your screen.

* Install the Web Publishing Wizard software, distributed freely by Microsoft Corp. to use this feature
of ISB.

Texture Mapping

Switching to the Texture Mapper window

To switch to the Texture Mapper window do one of the following:
. :‘)~ Texture Mapper Click the Texture Mapper tab on the Switch bar.

* Texture Mapper Choose on the View menu.
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Placing textures into the Texture Mapper window

To place a texture in the Texture Mapper window for editing:

* Double-click a textured face in the Perspective View window. The texture is displayed in the
Texture Mapper window. The face material becomes current material in the Material bar. The face
with texture is highlighted by a yellow frame in the Perspective View window:

To replace a texture on a face and in the Texture Mapper window:

. Drag a texture from the Texture gallery to the Texture Mapper window or to the
Material Preview window at the top of the Material bar. The new texture is placed in the Texture
Mapper window for editing. The face texture is also replaced in the Perspective View window.

Moving textures

To move a texture:

2 Click and drag the texture in the Texture Mapper window in any direction. If you drag while
the Shift key is pressed, texture movement is limited to the horizontal direction. If you drag while
the Ctrl key is pressed, texture movement is limited to the vertical direction.

See also:
"Decorating scene” example in the ISB's Quick Start Guide document.

Mapping the texture relative to a pivot point

To establish the pivot point:

E Double-click any point of a texture in the Texture Mapper window - a push pin appears stuck
into the texture at the click point.

To rotate a texture around the pin:

Drag the texture in the Texture Mapper window in any direction.

To stretch or shrink a texture relative to the point:

Drag the texture while the Shift key is pressed.

To rotate and stretch or shrink a texture simultaneously:

Drag the texture while the Ctrl key is pressed.
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To rotate a texture 180 degrees:

. il Click Central Symmetry on the Texture toolbar.

To rotate a texture 90 degrees counter-clockwise
. Igl Click Rotate on the Texture toolbar.

See also:

"Decorating scene” example in the ISB's Quick Start Guide document.

Mapping textures relative to a line

To establish the relative line:

1 EQ Double-click any point of a texture in the Texture Mapper window - a push pin appears stuck
into the texture at the click point.

2 EQ Double-click any other point of the texture in the Texture Mapper window - one more pin
appears, with a line connecting the two pins. Position the pins by dragging them on the texture to
establish mapping directionality.

To stretch or shrink a texture relative to the line:
‘ 1 ER

- Drag the texture in the Texture Mapper window in any direction - the texture is
stretched/shrunk relative to the line.

To dislce a texture relative to the line:

Drag the texture while the Shift key is pressed - the texture is displaced relative to the

To displace a_md stretch or shrink a texture relative to the line:

| - .\?

# Drag the texture while the Ctrl key is pressed - the texture is simultaneously displaced
and stretched or shrunk.

To mirror a texture relative to the line:
olo . )
e |_*_1 Click Mirror on the Texture toolbar.

To make a horizontal texture axis parallel to the relative line:

2|

. Iﬂl Click the Align Horizontal button on the Texture toolbar. We define vertical and horizontal
directions on the screen as texture coordinate axes when a texture is displayed without
transformations.

To make a vertical texture axis parallel to the relative line:

. Iﬁl Click the Align Vertical button on the Texture toolbar. We define vertical and horizontal
directions on the screen as texture coordinate axes when a texture is displayed without
transformations.
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See also:
"Decorating scene” example in the ISB's Quick Start Guide document.

Restoring the initial texture

To return a texture to default state:

. m Click Default on the Texture toolbar - the texture reverts to its original state.

Changing texture transparency

You can set the material transparency in the Material bar with the Transparency control slider.
To set the material transparency:

* Drag the Transparency control slider on the Material bar up to increase the material transparency
value.

* To revert to the opaque material:
. ﬁl Click the Opaque button.

See also:
"Decorating scene” example in the ISB's Quick Start Guide document.

Removing textures

You may remove a texture from a face to restore its initial color. You may also change the initial color.

To change the base color of the face under the texture, open the Material bar by Double-clicking the
Material Preview window:

* Click anywhere in the Color Circle, and then use the Luminosity slider below to adjust the color's
attributes.

* If you define a color using the Red/Green/Blue scales, you can look at this circle to make sure you
defined the color as you intended.

* To paint a face with the desired color, delete the current texture by clicking the Clear button on the
toolbar at the top of the Material bar.

To remove a texture from a face:

. E Click Clear - the texture is removed. The face returns to its original, non-textured base color.

See also:
"Decorating scene” example in the ISB's Quick Start Guide document.

Animating textures

To create animated (moving) textures:

. \ // Drag the green circle from the center red arm from the center of the texture animation
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control on the Material bar to set the direction and the speed of the texture’s movement. A longer
arm results in faster motion. To stop the motion:

. Iﬁl Click the Stop button on the Material bar.

See also:
"Decorating scene” example in the ISB's Quick Start Guide document.

Copy modified textures to faces

To spread a face material properties, including the modified from one face to the others:

1. & Click the Spread button on the Brush toolbar.

2. H Position the pointer over the face with the required material properties in the Perspective View
window. The pointer looks like a brush.

3. Hold the left mouse button.

4. Drag the material through all faces to be applied.

To spread a texture or color over the whole object:

1. 3’ Click Spread on the Brush toolbar.

2. ﬂ Position the pointer over the face with the required texture or color in the Perspective View
window. The pointer looks like a brush.

3. Double-click the face - all other faces of the object are textured or colored.

Notes:
* Transfer of material from a face of one object to the faces of other objects is impossible.

* Material transfer across parts, from one face to another, is impossible if there is any empty space,
even if the two parts belong to the same object (scene).

* Using the Fill and Spread operation, a face material can be spread without skipping over the blank
space or volume the part itself occupies. If there is a closed cavity inside a figure (the inner part of
it is cut out), its external and internal faces are filled by material independently.

* By Double-clicking a face, a face material is applied to all the faces of the frozen part of the scene
or current object. All other objects including its sub-objects are not changed. For example, if there
are two separate objects in a scene, the material will only be applied to the faces of the double-
clicked object.

* |If two isolated parts in a scene (object) are visually interconnected with a part belonging to another
object, they are not considered interconnected in the sense of face material transfers.

See also:
"Decorating scene” example in the ISB's Quick Start Guide document.

Texture Painting

Switching to the Painter window

The Painter window allows for pen and mouse-based drawing on textures and pictures.
To switch to the Painter window:

* Choose Painter from the View menu. The Plan (or Texture Mapper) window in the right part of the
ISB screen will be replaced with the Painter window.
The Painter toolbar is located in the upper part of the Painter window. It has buttons to create and
save pictures and textures. The Paint toolbar has sections to choose drawing tools, painting color
and its attributes. This toolbar is in the right part of the Painter window.
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See also:

"Editing textures and pictures” example in the ISB's Quick Start Guide document.

Creating a new picture or texture

Textures and Pictures are created while in the Painter window:
1 Choose Painter from the View menu to display the Painter window.

by
2 ﬁl Click the New picture or New texture button on the Painter toolbar Iﬁl The window
presents an empty canvas, upon which you will create or edit your picture or texture. The painter
mode allows you to write and draw on a picture or texture, to paint their parts with different colors
and to make transformations of selected parts.

Placing pre-existing textures or pictures into the Painter window

To place a texture or picture in the Painter window for editing make one of the following:
+

1 n’ﬂ"""ﬂ Display the Painter window. Drag the texture or picture from the corresponding
gallery into the Painter window. The pointer looks like an arrow with a picture.

2 In the Perspective View window, right-click a face with a texture or on a picture you want to
change. Choose Edit texture or Edit from the pop-up menu.

3 Double-click a picture in the Perspective View window, or on a texture in the gallery to edit it in the
Painter.

See also:

"Editing textures and pictures” example in the ISB's Quick Start Guide document.

Draw a straight line or rectangle

Click Line on the Paint toolbar to draw a line or click Rectangle to draw a rectangle.
Click a line width on the Width and Shape box to select a drawing width.

Click a color on the color toolbar to select a drawing color.

Drag the handle of the Transparency slider to define the color transparency.

Drag the handle of the Blur slider to define the color intensity.

Drag the mouse while holding down the mouse left button to draw a line or rectangle.

D OB W N P

Draw a free-form line

Click Pencil, Stylus or Brush on the Paint toolbar to select a drawing tool.

Click Weight on the Width and Shape box to select thickness of the drawing tool.
Click Color on the color toolbar to select a color.

Drag the handle of the Transparency slider to define the color transparency.
Drag the handle of the Blur slider to define the color intensity.

Drag the mouse pointer to draw.

o O~ W N P

Fill an area with a color

You may fill an area of connected points whose colors are about the same. To fill an area:
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1 Click the Fill button on the Paint toolbar.
2 Click a color on the color toolbar to select a color.
3 Drag the handle of the Transparency slider to define the color transparency.

4 Drag the handle of the Tolerance slider to define the tolerance, or allowable difference between
points of color to be replaced in the selected area.

4 Click anywhere in the area to be painted. The area is filled.

Using transparent colors

You can specify any color as transparent color while editing picture or texture. The information about
transparent color will be stored in the image file and used by the browser while viewing the scene.

To set current drawing color as transparent color:

* Choose Transparent Color on the Paint menu, and then click the Set item. Current drawing color
will be set as transparent in the image file.

To retrieve the color, specified as transparent color in the image file and make it current color:
* Choose Transparent Color on the Paint menu, and then click the Retrieve item.

To remove the transparent color information from the image file:

* Choose Transparent Color on the Paint menu, point on the Set command and click left mouse
button. Transparent color assignment will be removed.

Note:

* Transparent Color options are available only for GIF and PNG image file formats.

Manipulating selected areas

To select an area of the picture or texture:

1 Click Select on the Paint toolbar.
2 Draw a selection rectangle by left clicking and dragging with your mouse.

To move or copy the selected part over the picture or texture:

1 Click the movement mode in the Width and Shape control (movement mode is represented by two
icons, both sunset drawings differentiated by how the sun looks in a selection rectangle). To move
or copy a selected rectangle as a whole click the upper icon. To move or copy only those points of
the area whose colors are different than the current color selected in the Colors toolbar, click the
bottom icon.

2 Drag the selection area to move and place it.

To copy the selected area to the clipboard:

* Click Copy on the Standard toolbar or choose Copy on the Edit menu.
To clear the selected area:

* Choose Delete on the Edit menu.

To cut the selected area to the clipboard:

¢ Click Cut on the Standard toolbar or choose Cut on the Edit menu.
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Pick up a point color

You may pick a color to paint with from any point on the picture or texture. To pick a color:

1 Click Select Color (eyedropper) on the Paint toolbar.

2 Click the desired color on the existing picture or texture. That color becomes the current color and
is placed on the current color box of the Painter toolbar.

Zoom In a picture or texture

To magnify an area of a picture or texture:

1 Click Zoom on the Paint toolbar.
2 Click anywhere in the area to be magnified.

To change the picture or texture magnification:

1 Click Zoom on the Paint toolbar again.

2 Click the appropriate magnification value in the Width and Shape box to zoom in or out from the
original view.

To return the picture or texture to its original size:

1 Click Zoom on the Paint toolbar.
2 Click anywhere in the picture or texture again.

On-line picture or texture editing

You may edit a picture or texture already placed into a scene. When you edit on-line all changes are
immediately displayed in the Perspective View window.

To make edit a picture or texture on-line:

1 Display the Painter window.

2 Double-click the desired texture or picture in the Perspective View window. The picture or texture
is placed on the canvas in the Painter window. Its name and category is displayed in the Painter
window toolbar.

3 Edit the picture or texture. All editing is displayed in the Perspective View window.

Resizing a picture or texture

Z

1-’//.%

. Drag the black box on the edge of the picture or texture. With an increase of the image
canvas the number of pixels increases. The picture or texture shown in the window is unchanged,
and the additional canvas space is initially painted white. With a decrease in the size of the image
canvas, the picture or texture is cropped along the new borders of the canvas.

Saving a picture or texture

You can save a picture or texture in any of BMP, GIF,JPG or PNG image file formats supported in ISB.

To set the image file format for saving a picture or texture:
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* Choose Format command on the Paint menu, then point to one of file formats in the drop-down
sub-menu and click the left mouse button.

To save a picture or texture to a gallery:

1 To rename a picture or texture enter the new name in the Name field of the Painter window
toolbar.

2 To define another category enter the new name in the Category field of the Painter window toolbar.

3 El Click Save on the Painter window toolbar. The edited picture or texture is saved.

Instead of saving a picture or texture in a gallery you may save them to any folder and file location
available to your system.

To save a picture or texture to the file:

1 Choose Save as from the Paint menu. The dialog box for file specification appears.
2 Click a drive name or folder name.

3 In the File Name box, type a name for the picture or texture.

4 In the Save as type field, choose a graphic file format.

5 Click Save.

Note:

ISB stores the texture galleries in the ISB\Textures directory by default.

Controlling Gallery Resources

Moving, adding and deleting gallery resources

You can move, add or delete resources in each gallery.
To move, add or delete gallery resources:

1 Right-click anywhere in the gallery. The pop-up window appears.

2 Click the Explore menu item. The standard Windows Explorer window with the gallery’s file names
appears.

3 Add or delete files using the Windows Explorer. All modifications are immediately displayed in the
appropriate gallery.

Working with the Scene Resources and Resource References

To open the Resources dialog box, choose Info command on the File menu and then click the
Resources tab. This dialog box allows you to view and modify the references to resource files in the
Scene:

* Resources list box. In this box you can view the list of all resource files, used in the Scene. You
can set the sorting order by file Name, Type, Size, use Count and by Folder name. To set the
desired sorting order, click the corresponding tab header. The number of selected resource files
and their size are displayed on the bar at the bottom of the list box. If there is no files selected,
total number of resource files used in the Scene and their size are shown instead. The files, which
are referenced in the Scene file, but not available or corrupted format are shown with red cross
over the file icon.

* View use button. Press this button to show the place in the Scene where the corresponding
resource is used. The camera smoothly moves to the face with a texture, picture, movie or sound
automatically. If the resource file is used on several faces of the Scene items, then the first face is
displayed. You can switch to the other face with the help of the slider control to the right of View
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Use button.

* Slider control. Use this control to view the specific face with resource, applied to many faces. The
left position of the Slider corresponds to the current camera position in the Scene. When you move
the slider to the right, a camera moves to show the face, which uses the selected resource file with
increasing reference count. For example, if a textured cube is present in the Scene, than the
texture file is used 6 times. When you click View use button the first counted by usage face of the
cube is shown in the Perspective view window. If you move the Slider control to the right the faces,
using the sane texture with increasing usage count are displayed.

* Preview window. You can preview the image of texture, picture or movie frame in this window.
For a sound (both WAV and MIDI formats) file a Play button substitutes the preview image. Click
this button to play the sound. For an Internet shortcut the preview image is replaced by the button
with the icon of your operating system default Internet browser program. Press this button to follow
the link.

¢ Rename button. Press this button to rename the selected resource file.

e Change button. Press this button to open a dialog for replacement of selected resource file by
another. The replacement takes place on all faces, using this resource file.

To apply changes, made in resource files references click the OK button.
To cancel all changes, made in resource files references click the Cancel button.

Working with the resources, used in the Scene

While editing the scene you can get the information about the resources, used in it and modify them.
This is useful if you need to check the space occupied by resources, find the place in the scene where
the particular resource is used, resolve the problems with the resource, referenced in the file, but not
found in the location specified in the scene. You can do these operations with the help of Resources
dialog box.

To open the Resources dialog box:

¢ Choose Info command on the File menu and then click the Resources tab.

The Resources dialog box appears, which contains the list of all image and sound files, referenced in
the scene along with the Internet shortcuts, attached to the scene objects and pictures. You can sort the
resources by name, size, type, reference count, folder name in ascending or descending order.

B8 The resources references for which the corresponding files are not found are shown in the list by the
icon with the red cross .

To set the resources sorting criteria:

* Click the corresponding header tab.

To invert the resources sorting order keeping the same sorting criteria:
* Click the same header tab once more.

Below the list of resources there is a status bar, showing either the total number and size of resources in
the scene or the number and size of the selected resources.

To select a resource:
* Click its name in the resources list.
To select a group of resources:

* Click each resource name, holding down the CTRL key on the keyboard. All resources you have
clicked will be selected. Or

* Click the first resource name, hold down the Shift key and click the last resource name in the list.
All resources, located between the first and the last names in the list will be selected.
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You can perform the following operations with the selected resources:

View the use of single selected resource
Rename the resources and change the image files format.
Change the resource reference to another file of the same type

Viewing where the selected resource is used in the scene

In the Resources dialog box you can view the scene item, using the selected resource. For this:

1 Choose Info on the File menu and then click the Resources tab. The Resources dialog box
appears.

2 Select the resource by clicking its name in the resources list. Scroll the list using the vertical and
horizontal scroll bars to make the resource file name visible.

3 The preview image of the selected resource (or the last selected resource in the group) is shown in
the small preview window in the bottom right corner of the Resources dialog box. For sound files
and Internet shortcuts the button, launching the system default program, associated with the file
type is shown instead of the image. Click the button to check the Internet link or play the sound.

4 M Click the View Use button. The camera moves to the position, suitable for viewing
the face with the selected resource.

5 Click the View Use button once more. The camera moves to the next face, using the same
resource. The reference count to the resource in the scene file is displayed by position of the slider
located to the right of the View Use button and is written below it. The first number shows the
reference number, the second number - total number of references to the current resource in the
scene file. You can move the slider to set the reference number to the resource you want to view.
The camera moves to the face, having the specified reference number to the resource in the scene
file.

Using the View Use button you can find a specific place in the scene, containing the picture, texture,
movie, sound or Internet shortcut. This is helpful, for example, when you have lost the resource file and
need to find where it is referenced in the scene. Then you can change the resource file reference to
another one or rename the existing resource file and copy it to the specified folder. While renaming the
image file you can also convert it to one of available image file formats: BMP, GIF, JPEG or PNG.

Related topics:

* Working with the resources, used in the Scene
* Renaming resources
* Changing the resource reference in the Scene file

Renaming resources

While editing the scene you can change the file name and location of resource, referenced in the scene.
The resource file under the specified new name is automatically copied into the folder you have
specified. This is useful if, for example, you decide to give new names to the files used in the scene and
to edit them later keeping the original files unchanged.

To rename the resource file, used in the scene:

1. Choose Info on the File menu and then click the Resources tab. The Resources dialog box
appears.

2. Select the resource by clicking its name in the resources list. Scroll the list using the vertical and
horizontal scroll bars to make the resource file name visible. To select a group of resources click
each resource name, holding down the CTRL key on the keyboard. All resources you have clicked
will be selected. Or click the first resource name, hold down the Shift key and click the last
resource name in the list. All resources, located between the first and the last names in the list will
be selected.
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Fename... . . -

3. ;I Click the Rename button. Rename Resources dialog box appears. In this dialog box
you can change the name of the resource file, change its location and perform format conversion
for the images, used as pictures, movies or textures.

4. Change Location. Place mark in this checkbox and enter a new path to the file in the field below.
The file with the resource will be copied to the location you have specified and the scene will

reference to the file at this location. To open standard Windows Choose Folder dialog press —
the Browse button.

5. Change Name. Place mark in this checkbox and enter new file name in the field below. Do not
enter the extension in this field - the file extension will be set according to the resource file format
automatically.

6. Change Format. Place mark in this checkbox and select the image file format from the list of
available formats. This option is available for image files only. You can not change the format of
sound file or Internet shortcut. After you have changed the resource format a new file with the
specified format and filename extension is created in the folder, specified in the Change Location
field above. The scene file will contain the reference to this new file. The original resource file is not
deleted.

7. Click the OK button. The Copying Resources dialog box with the information about the process of
copying files is displayed.

8. The resource file or group of files will be converted to the new format (if specified) and copied to
the folder, specified in the Change Location field under the name, specified in the Change Name
field. The filename extension will be automatically set to the default extension for file format
specified.

9. You can interrupt copying by clicking the Abort button.

10. After the copying is complete click OK to close the Copying Resources dialog box. The Rename
Resources dialog will be closed too and you will return to the Resources dialog box.

To make the changes permanent and close Resources dialog box:
e Click the OK button in the Resources dialog box.
To cancel renaming of resources you have made while the Resources dialog box has been opened:

¢ Click the Cancel button. All references to the resources in the scene file will be reset to the state,
which was before you have opened the Resources dialog. New files you have created while
renaming the resources will not be deleted.

Notes:

* You can not change the file format for the sound files.
* You can not rename the Internet shortcut.
* You can not change the name for the group of selected files in the Rename Resources dialog box.

* While converting the group of files to the other format only image files are converted, the other files
are ignored.

* A movie in ISB is a set of files, each file in a set is treated as a movie frame. To rename a movie
you have to rename all movie frame files.

Related topics:

* Viewing where the resource is used in the Scene
* Working with the resources, used in the Scene
* Changing the resource reference in the Scene file

Changing resource reference in the scene file

You can change the resource reference in the scene file to point it to another file, located in any folder.
This is useful if, for example you decide to change the particular texture on all faces of multiple objects
in the scene at once or you need to substitute missing resource file by another one.

To make the resource reference in the scene pointing to another file:
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1 Choose Info on the File menu and then click the Resources tab. The Resources dialog box
appears.

2 Select the resource the reference to which you decide to change.

Ch . . o

3 ﬂl Click the Change button. Change Resources dialog box appears. This is Change
resource dialog box. In this dialog box you can replace the reference to the selected resource file
in the scene.

4 From area. In this area the Name, Path, Type and Size and preview image of the resource file to
be replaced are displayed.

5 To area. Enter the name and path to a new resource file in the corresponding fields. To find a file
click Browse button. Preview image of the resource and its file size are also displayed in this area.

6 To remove the resource from scene place mark on the Nothing checkbox. All references to this
resource will be removed from the scene file.

7 To apply changes to the scene resource file reference click OK.
8 To cancel changes click Cancel.

Related topics:

* Viewing where the resource is used in the Scene
* Working with the resources, used in the Scene
* Renaming resources

Controlling the navigation type

The Scene Info dialog at the Navigation tab allows you to control the navigation type which is used in all
major VRML browsers. Choose Info on the File menu and then click the Navigation tab. The
corresponding dialog box appears.

* Allowed navigation types. Mark the check box to use the browser’s navigation type. The
browser’s navigation user interface will be restricted to navigation types specified in the list. NONE
navigation disables and removes all browser-specific navigation user interface forcing the user to
navigate only mechanisms provided in the scene such as Anchor nodes or scripts.

* Set as Default Type. Press this button to apply Allowed navigation types by default for all scenes
you will create.

* Avatar size. In this section you can set the physical dimensions of the avatar (the abstract
representation of the user in a VRML world) for the purpose of collision detection and terrain
following. Camera is used to view a scene; the position of the camera is considered to be close to
the avatar's eyes. The Collision distance parameter specifies the minimal distance between the
camera’s position and an any collision geometry in a VRML world. Height above the terrain - the
height above the horizontal surface at which the browser should maintain the camera. Height of
the footstep - the height of the tallest object over which the viewer can move. All parameters are in
meters.

* Viewer settings. The Headlight specifies whether a browser should turn on a headlight. The
speed parameter determines the speed with which you move in meters per second.

You have changed this scene since the last time you saved it to disk. Before ISB closes it, you have a
chance to update the disk copy.

Yes Click this button to save the scene to disk. If the file hasn't yet got a name, you'll see a dialog
asking you to specify the file to save to.

No Click this button to irretrievably discard the changes you've made since the last save.
Cancel Click this button to abandon the operation completely and return to editing the scene.
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Setting ISB options

Choose Options... on the Tools menu and then click the corresponding tab.

General
This dialog box allows you to define the general parameters of the scene.

* Use compression for. Mark the checkbox near the corresponding item to save new scenes,
objects and previously published scenes in compressed format.

* Undo buffer size. Specify a limit for the number of Undo operations.

* Play background MIDI. Mark the checkbox to play a MIDI file attached to a scene. Clear the
checkbox if you don’t want the file to play.

* Auto Repeat. Mark the checkbox to repeat MIDI after it is finished. Clear the checkbox if you want
to play MIDI once.

* User info. Specify the user and company names in the corresponding fields. These names will be
documented in the scene’s VRML 2.0 file.

. %I Click this button to open the HTML Options dialog box. You may edit the HTML file

to be uploaded to your Web page in this dialog box. A default HTML text file is already loaded,
however you may modify the text manually prior to posting the scene.

The HTML options dialog box

Here you can edit the HTML file to be created with Post to Web command. A default document is
displayed in the editing box. You can edit HTML format text manually or insert the HTML language
keywords automatically.

To edit HTML document manually:
* Click anywhere on the editing box and enter a text.
To insert HTML keywords:

* Position a cursor in the place, where you want to insert a keyword into the document. Click Insert
button and then click a keyword on the popup list of available keywords. A keyword will be inserted
to the right from the cursor’s position. Refer to the HTML language syntax description before you
begin editing a document.

To cancel all editing operations and restore the original document:
* Click Reset button.

To finish editing and close the HTML options dialog:

* Click Ok

To cancel current editing of document:

¢ Click Cancel.

Plan

This dialog box allows you to specify a grid for the Plan window and to set the thickness of the walls for
polygonal shapes.
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Grid. Mark the checkbox to turn the Grid on, or clear the checkbox to turn the Grid off.
Spacing. Specify the Grid cell in meters.

Snap. Specify the grid snapping proportion: select 1:1 in the Snap box to specify snap to grid cell,
select 1:2 to specify snap to 1/2 cell, etc. Select None to turn the grid snapping off.

Guides. Mark the checkbox to turn on the Guide lines in the Plan window. Enter the Top Guide
and Bottom Guide heights in meters in the Top and bottom fields.

Thickness. Specify the thickness of the wall, floor and ceiling for the Room and Wall polygonal
shapes.

Spline. Specify the default spline parameters.

Camera

This dialog box allows you to control scene appearance and navigation in the Perspective View window.

Rendering engine. Select a rendering mode. The 256 Color/High Color/True Color Software 3D
Render Engine options are preferable if your display works in the corresponding color mode. The
Render Engines with MMX in their name are available only for the computers with processors
supporting Intel's MMX instruction set.

Default picture resolution. The number of pixels of picture image per 1 meter of the virtual space.
To make a picture larger when it is on screen, decrease the number in the Horizontal and/or
Vertical field.
K.evboard Mavigation... . . N . .
S LA EEE Click this button to open the Keyboard Navigation dialog box. In this
dialog box you can re-assign the keys for the keyboard navigation commands.

Galleries

This dialog box allows you to control the ISB resources.

Category. Select the name of the gallery.

Path to the resources. Enter the name of the folder with the gallery resources or click the Browse
button to search for the gallery folder.

Include subfolders. Mark the check box to use resources from the subfolders of the folder
specified in the Path to the resources edit box. If the checkbox is marked, the subfolders are
shown in the corresponding gallery with a tab. The name of the tab coincides with the name of the
subfolder.

Preview size. Specify the size of the screen area for the resource preview. The size is specified in
pixels.

Sort by. Define the sort order for the resources. They can be sorted in ascending order by name,
or in ascending or descending order by creation date.

Show ToolTips. Mark the checkbox to display tool tips for gallery resources.
Enable animation. Mark the checkbox if you want a resource to rotate when you point to it.

Allow fast load. Mark the checkbox to save a resource preview image after the resource is
loaded. This option is intended for complex resources such as scenes or objects. These resources
are displayed much faster when their preview images are stored on the disk. If you modify a
resource its image is automatically updated.

Show titles. Mark the checkbox to display names of gallery resources.

Texture Mapper

This dialog box allows you to define texture tiling parameters.
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Default scene texture tiling. The number of meters of virtual space per one tiling unit. These
parameters are used when you drag and drop a texture from the Texture gallery to a non-textured face
in the scene.

Keyboard Navigation dialog box
To open the Keyboard Navigation dialog box:

* Choose Options on the Tools menu, then click the Camera tab and click the Keyboard Navigation
button.

Keyboard Navigation |

Actions: Preszs new sharbout key: Assigr
n s |Nu:-ne |

[ Hemave |
b ave ta the Left
b ove to the Right Feset Al |
tMove Up =
b v Dt Current keps:
Turn Left 8
Turn Right Mum 8
Turn Up l Up
Linear speed: Angle speed: Aocelaration:

|4 3: mzec IEEI 3: *leec |3 3: timesz
(] I Cancel | Help |

In this box you can re-assign the keys for the keyboard navigation commands and set the navigation
properties:

* Actions. Select the navigation command in this list by clicking its name.

* Press new shortcut key. Click this field and then press on the keyboard a new shortcut key for
the selected command. The key nhame you have pressed is displayed in this field.

e Currently assigned to. The navigation command name associated with the key you have pressed
is displayed below this phrase. If the key is free from any previous assignment it is displayed as
unassigned.

e Current keys. A list of the keyboard keys, associated with the selected camera navigation
command is shown below this line. There may be any number of keys assigned to one navigation
command.

* Linear speed. Set the linear camera motion speed in meters per second in this field. The camera
moves in virtual space with this speed while you are holding down a key, assigned to the camera
linear motion command.

* Angle speed. Set the camera rotation speed in degrees per second in this field. The camera turns
with this speed while you are holding down a key, assigned to the camera rotation command.

* Acceleration. Set the value of linear or angular camera motion acceleration coefficient. The
motion will be accelerated by this value while you hold Shift key together with the navigation
command key.

Bz . . . N
. ﬂl Click this button to assign the new keyboard key to the selected navigation
command.

R . . . .
. £I Click this button to remove currently assigned keyboard key from a list of keys
associated with the selected navigation command.

Reszet Al . . .
. LI Click this button to revert to the default ISB keyboard commands assignments.

To make all keyboard commands assignments permanent and close the dialog box:

¢ Click the OK button
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To cancel all keyboard assignments you have made and close the dialog box:

¢ Click the Cancel button.

Customizing Toolbars

Display or hide toolbar

To display or hide a toolbar:

1 Choose Toolbars from the View menu. The Toolbars dialog box, listing the default toolbars
appears.

2 Mark the toolbar checkbox to display the toolbar, or clear the checkbox to hide it.

Note:

To quickly display or hide a toolbar right-click any toolbar. After the pop-up menu appears click the
toolbar name to affect its display. A check mark indicates the toolbar Is active and displayed.
Clicking it again removes the check mark and hides the toolbar.

Disable or enable custom toolbar

You may enable or disable a custom toolbar in the Plan, Texture Mapper or Painter window.
To enable/disable a toolbar:

1 Choose Toolbars on the View menu. The dialog box with toolbar names appeatrs.

2 Click the name of the custom toolbar to be disabled in the current window.

3 Click Enable/Disable to enable/disable the custom toolbar. The name of the button is switched
between Enable or Disable each time it is clicked. The name of the toolbar is also enabled or
disabled from the list of available toolbars in the context menu, which opens if you right-click any
toolbar on the ISB screen.

Note:

You cannot disable ISB’s built-in toolbars.

Move a toolbar

1 Point between buttons on a toolbar, or point to the toolbar title bar if it is a floating toolbar.

2 Drag the toolbar to a new location. If you drag it to the edge of an ISB window, the toolbar docks to
this edge automatically.

Resize a toolbar

To resize a floating toolbar, drag any of its sides.

Note:

* You cannot resize a docked toolbar.

* Floating toolbar. A toolbar that is not docked to the edge of any ISB window. Such a toolbar has a
title on the top of its window.

* Docked toolbar. A toolbar that is attached, or anchored, to an edge of ISB window. Its window has
no title. You may dock the toolbar below the menu or to the left, right, top, or bottom edge of the
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window. When you drag a toolbar to the edge of the window, the toolbar outline snaps to the edge.
When you drop the toolbar after its outline snaps, it docks to the edge of the window.

Restore a built-in toolbar

1 Choose Toolbars on the View menu. The dialog box with toolbar names appeatrs.
2 Click the name of the built-in toolbar to be restored.
4 Click Reset. The built-in, default state of the toolbar is restored.

Create a custom toolbar

To create a custom toolbar:

Choose Toolbars from the View menu. The dialog box with toolbar names appears.
Click New. The Customize Toolbars dialog box appears.
In the field “Toolbar name enter the name of the new toolbar.

Mark the “Available in global scope checkbox to make the toolbar available while working in the
Plan, Texture Mapper, and Painter windows. Clear the checkbox to make the toolbar available
during work in the current view only.

Click OK. An empty toolbar appears on the screen. The Customize Toolbars dialog box appears.
In the Categories box, click the category that contains the desired button.

Drag the desired button onto the new toolbar.

Repeat the last two steps for all required buttons.

Click Close. The Customize Toolbars dialog box disappears.

A W N P
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Delete a custom toolbar

To delete a custom toolbar:

1 Choose Toolbars from the View menu. The Customize Toolbars dialog box appears.
2 Click the name of the toolbar to be deleted.
3 Click Remove. The toolbar is removed.

Note:

¢ You cannot remove the ISB built-in toolbars.

Rename a custom toolbar

To rename a custom toolbar:

1 Choose Toolbars on the View menu. The Customize Toolbars dialog box appears.
2 Click the name of the toolbar.

3 Enter the new name in the Toolbar name field.

4 Click Close. The toolbar is renamed.

Note:
You cannot rename the ISB built-in toolbars.
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Add or delete a toolbar button

To add a toolbar button:

1 Choose Customize on the Tools menu. The Customize Toolbars dialog box appears.

2 In the Categories box, click the category that contains the desired button. All buttons of this
category appear in the Buttons box.

3 Drag the desired button from the Buttons box to the new toolbar. The button appears on the
toolbar.

4 Click Close. The button is added.

To delete a toolbar button:

1 Hold down the Alt key and then drag the button to be deleted from the toolbar onto any ISB
window.

2 Release the Alt key. The button is deleted.

Note:
If the Customize Toolbars dialog box is open you may drag buttons without pressing the Alt key.

Change the spacing between toolbar button

To increase a space between two toolbar buttons:

1 Hold down the Alt key and drag the right button a little bit to the right.
2 Release the Alt key. The distance between the tools is increased.
3 Repeat the last operation for all other buttons, with the exception of the upper left.

To decrease a space between two toolbar buttons:

1 Hold down the Alt key and drag the right button a little bit to the left.
2 Release the Alt key. The space is decreased.
3 Repeat the last operation for all other buttons, with the exception of the upper left.

Move or copy a toolbar button

To move a toolbar button to another toolbar:

1 Hold down the Alt key and then drag the button to the required toolbar.
2 Release the Alt key. The button is moved.

To copy a toolbar button:

1 Hold down the Alt and Ctrl keys and then drag the button to the required toolbar.
2 Release the Alt and Ctrl keys. The button is copied.
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Troubleshooting

* A texture won't spread to another face.
The face belongs to another object. You can only spread textures over faces of the same object.

* Only the top view of a plan is printed as a result of the Print command on the File menu.
You can only print views shown on the screen. To print a front, view make sure it is visible.

* The objects in the Object gallery are not textured.
This means the textures are loading. In this case the rotating globe is shown on the bottom of the
ISB window. The objects will display any textures after they are loaded.

* The picture is too small when placed into the Perspective View window.
If you want the pictures to be larger when you place them into the Perspective View window click
Options on the Tools menu, then click the Camera tab. Define smaller values in the Horizontal and
Vertical edit boxes. These boxes specify how many pixels of picture imaging correspond to one
meter of virtual scene.

* CosmoPlayer doesn’t process an URL link when you click the object.
If an object has an URL link as well as a sound file attached to it, CosmoPlayer will only play the
sound after the object is clicked.

* A scene isn't textured when viewing with CosmoPlayer.
If you save the scene using the Save or Save As command on the File menu, the scene
references textures, pictures, movies, and objects locally. For correct URL links which allow you to
publish a scene and view it using any VRML viewer use the Publish or Post to Web command
from the File menu.

* When a picture is placed into another location it changes its size.
Each time a picture is placed onto an object’s face ISB calculates an appropriate size, one
corresponding to the size of the face. Place a picture in the correct position before specifying its
size.

* The Cut, Copy or Extract commands are not working in certain cases. The Extract, Cut and Copy
operations are not available to the Room and Walls shapes and to convex custom shapes.
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Reference

This reference contains brief information on ISB’s menus and toolbars. Here, you can find

some useful features that were not explained above.

Main Menu

ISB has a standard Windows menu with pull-down menus for several categories of

commands.

File

Contains commands for managing files, choosing scenes in the Scene gallery, getting scene

info, printing the plan and exiting ISB.

New Creates a new empty scene with default camera position, grid
spacing, etc.

Open Opens a scene from the specified file.

Choose Opens a scene from the Scene gallery (Double-click the selected
scene).

Save Saves the current scene into the same file. The scene can be
saved in VRML 2.0 or VRML 2.0 compressed (gzip) format.

Save as Saves the current scene under a specified file name. The scene
can be saved in VRML 2.0 or VRML 2.0 compressed (gzip)
format.

Info Displays information about the scene such as number of faces,
pictures, movies, etc.

Publish Creates a directory for your scene and copies the .WRL file and
all scene resources like textures, pictures etc. into the directory.
This creates a distribution package of your 3D scene which you
can publish on the Web. The scene can be saved in VRML 2.0 or
VRML 2.0 compressed (gzip) format.

Post To Web Uploads your 3D space to a WWW server.

Set Background Opens the Background dialog which allows you to set the scene
background images and landscape.

Attach MIDI Attaches a MIDI file to the current scene. This file plays while the
scene is loading.

Detach MIDI Detaches the MIDI file from the current scene.

Print Setup Define printer parameters.

Print Prints scene plan.

Exit Exits ISB.

Edit

Contains commands for scene editing. ISB has two different clipboards, used for

cutting/copying/pasting operations: standard Windows Clipboard for image data and special

ISB clipboard for scene geometry data.

Undo Cancels the latest editing operation.
Redo Redoes the last operation that was undone.
Cut Cuts the selected part of scene, object or image or the entire

selected object and places it on the clipboard. For the shape,
included into the scene or object this command is equivalent to
the Extract shape command, except that it places the removed
part of the scene or object on the clipboard.
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Copy

Copies the selected part of the scene, object or image, or the
entire selected object and places it on the clipboard.

Paste

In the Scene Assembling or Object Editing mode inserts the object
currently stored in the clipboard to the scene. In the Painter mode
inserts the Windows Clipboard image data into the edited picture
or texture.

Delete

Deletes the selected part of the scene, object or image, or the
entire selected object, without placing it on the clipboard. When
deleting a shape, included into the scene or object, this command
is equivalent to the Extract shape command.

View

Contains commands for displaying/hiding various ISB screen elements.

Toolbars Displays or hides selected toolbars, creates new toolbars and
resets toolbars to their default settings.

Switch Bar Displays/hides the Switch bar located at the bottom of the Plan
windows, which allows you to switch between the ISB modes by
clicking the corresponding tabs.

Status Bar Displays/hides the status bar located in the bottom line of the
screen.

Scene Plan, Switches between these modes of ISB operation.

Object Plan,

Texture Mapper,
Painter

Perspective View

Displays/hides the Perspective View window.

Clipboard Displays or hides the Clipboard Content window. Clipboard
Content window is located by default at the bottom right corner of
the ISB screen in the Basic layout and shows the items placed
onto the ISB clipboard as a result of Cut or Copy operations.

Scene tree Displays/hides the Scene tree window.

Scenes Displays/hides the Scene gallery.

Textures Displays/hides the Texture gallery.

Pictures Displays/hides the Picture gallery.

Movies Displays/hides the Movie gallery.

Shapes Displays/hides the Shape gallery.

Objects Displays/hides the Obiject gallery.

Camera

Contains commands for controlling ISB’s camera.

Align Horizontal

Makes camera’s horizontal axis parallel to the scene horizon.

Align Vertical

Makes camera’s longitudinal axis parallel to the scene horizon.

Go To Object

Move camera closer to the current object.

Set Light Direction

Sets a light source direction of the scene towards the active
camera view.

Duplicate Create a new camera at the same location and with the same
orientation as the current camera.

Rename Specify a new name for the current camera.

Delete Deletes the current camera. Available only if there are two or

more cameras.
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Use collider

Enables or disables collision detection while navigating the
camera in the Perspective View window. With Collision detection
ON the camera can not move through the faces.

Gravity

Enables or disables the gravitation effect on the current camera
during the navigation in the Perspective View window. With
Gravitation ON the camera always falls down on the face under it.
If there is no face under the camera, the gravity is turned off
automatically.

Object

Contains commands to manipulate scene objects.

New Empty object - creates a new object as a sub-object of current
object and switches ISB to the Object Editing mode.
Box - creates new VRML primitive object Box
Cone - creates new VRML primitive object Cone
Cylinder - creates new VRML primitive object Cylinder
Sphere - creates new VRML primitive object Sphere
Plain Text - creates new VRML primitive object Text
3Dtext Creates a text string, composed from 3D symbols as a new
object. You can enter text and format it with any of the True Type
fonts installed in your Windows system.
Import Imports an object from a 3DS file into the Object gallery.
Save Saves the current object. The object can be saved in VRML 2.0 or
VRML 2.0 compressed (gzip) format.
Manipulate Enables the Object Manipulator in the Perspective View window.
Mirror Mirrors current object from the vertical arm of its Object
Manipulator
Add Shape Adds the current shape to the scene.
Extract Shape Extracts the current shape from the current object.
Attach Sound Attaches a sound file (WAV) to the selected object.
Play Sound Plays the sound file (WAV) attached to the selected object.
Detach Sound Detaches the sound file from the selected object.
Link URL Attaches an URL to the selected object.
Remove URL Removes the URL from the selected object.
Layout
Contains commands to control screen layout.
Basic This is default ISB layout. This layout allows you to assemble
scene from ready elements and decorate your virtual world.
List Opens a list of custom layouts. You may add a new layout to the
list and use it in your work.
Tools
Contains commands for setting ISB parameters and creating new shapes for the Shape
gallery.
Customize Customizes the toolbars.
Options Sets ISB parameters. The parameters control screen appearance,
editing, rendering, navigation, resources and other options.
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Record Shape

Starts recording of merging and carving operations resulting in a
new shape. After the recording is stopped you can save recorded

gallery.

shape (command sequence - macro command) into the Shape

Stop Recording Stops recording and opens a dialog box to save the new shape.

Help
Contains commands to get help and additional information on ISB

Help Topics Displays the ISB Help window.

Tip of the Day Displays an ISB tip.

Product News Downloads the ISB news page from the ParallelGraphics Web

site.

ParallelGraphics Downloads the ParallelGraphics home page.

Home Page

About ISB Displays the ISB version number and copyright information.
Text

Contains commands for editing the Plain Text object in the Object Editing mode.

Format Opens the Format dialog box for the Plain text
object.
Save Text Saves Plain Text object in the object gallery.

Attach Sound

Attaches a sound file (WAV) to the selected
object.

Play Sound

Plays the sound file (WAV) attached to the
selected object.

Detach Sound

Detaches the sound file from the selected
object.

Link URL Attaches an URL to the selected object.
Remove URL Removes the URL from the selected object.
Toolbars

Toolbars include control buttons. Some are shortcuts to menu commands while others appear
only in toolbars. The toolbars of the Basic layout are described below.

Standard

Contains buttons for managing files as well as selecting and editing scene.

D|E|o| o] & |B|@]S(w

El New - Shortcut to the File/New command.

El Open - Shortcut to the File/Open command.
=1
El Save - Shortcut to the File/Save command.
il Undo - Shortcut to the Edit/Undo command.

2' Redo - Shortcut to the Edit/Redo command.
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il Cut - Shortcut to the Edit/Cut command.

-
Copy - Shortcut to the Edit/Copy command.

& Paste - Shortcut to the Edit/Paste command.
%l Print - Shortcut to the File/Print command.

Help - Provide context help.

Plan
Contains buttons for mode selection, zooming, displaying the ruler, guides and grid, as well
as fitting plan to the Plan window and browsing through the Scene tree.

& |2 Q|| e | & | B8] |

ﬁl Build Mode - Turns the Build mode on/off. In this mode, you can perform Boolean
operations with shapes from the Shape gallery. Boolean operations consist of adding shapes
to the scene or extracting shapes from the scene to create complex 3D objects.

Ql Polygon Mode - Turns the Polygon mode on/off. In this mode, you can specify the
underlying polygon and then create a solid polyhedral, walls, room or pyramid using one of

the Edit toolbar buttons: EI El El or ﬁl

gl Zoom Mode - Turns the Zoom mode on/off. In this mode, you can reduce or increase
view magnification as well as select an area in the Top or Front View windows for zooming.
To select an area, draw a rectangle with the mouse. The area is immediately magnified after
you release the left mouse button.

@l Move Plan Mode - Turns the Move plan mode on/off. In this mode, you move both views
in the Plan window in the drag direction.

Igl Zoom Out - Reduces magnification.

gl. Zoom In - Increases magnification.

b Ruler - Displays/hides the Ruler window.

= Fit to Scene - Adjusts view size to fit both views to their windows.

El Fit to Object - Adjusts the current object view size to fit both views to their windows.

Edit
Contains the buttons for editing the scene and creating new shapes.

| 3| X |2 |u || & |

il New Object - Shortcut to the Object/New command.
@ Add - Shortcut to the Object/Add Shape command.
® Extract - Shortcut to the Object/Extract Shape command.

f Solid - Creates a solid polyhedral after the vertexes of the underlying polygon are
defined. Accessible in the Polygon and Spline modes.

H Walls - Creates walls after the vertexes of the underlying polygon are specified.
Accessible in the Polygon and Spline modes.

El Room - Creates a room after the vertexes of the underlying polygon are specified.
Accessible in the Polygon and Spline modes.
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ﬁl Pyramid - Creates a pyramid after the vertexes of the underlying polygon are specified.
Accessible in the Polygon and Spline modes.

Camera
Contains the buttons for camera control.

] %[ =0] & =

Duplicate - Shortcut to the Camera/Duplicate command.

b Align Horizontal - Shortcut to the Camera/Align Horizontal command.
ijl Align Vertical - Shortcut to the Camera/Align Vertical command.

@I Go To Object - Shortcut to the Camera/Go To Object command.
iﬁl Collider - Shortcut to the Camera/Use Collider command.

Brush

8| %] 2]

ﬂ Spread - Spreads a material from one face to an adjacent face. To spread a material:
1. Click the Spread button.
2. Inthe Perspective View window, move the mouse pointer to the face with a required
material.
3. Hold the left mouse button.
4. Drag the material to any adjacent face.

@l Fill - fills a face or an object with the material from the Material bar.
When this button is pressed:
- If you single click a face in the Perspective View window, Fill copies the material from
the Material bar to this face.
- If you Double-click a face in the Perspective View window, Fill fills all connected faces
of the object with the material from the Material Bar.

il Pick - copies the material properties of a face into the material bar. To copy the material
properties of the face in the Material bar:
Click Pick button and then click the face in the Perspective View window.

Texture
Contains buttons for texture editing with mapping operations.

H|R|Z]4 | a2 8|5

El Shrink - Reduces the texture image tiling period on the face.

Expand - Increases the texture image tiling period on the face.

El Orthogonalize - Makes the texture axes perpendicular to each other.
il Central symmetry - Rotates the texture image 180 degrees around a pin.
b Rotate - Rotates the texture 90 degrees counter-clockwise around a pin.

-
= | Mirror - Mirrors the texture relative to the line between the two pins.
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ﬂl Align Horizontal - Rotates the texture image to make its horizontal axis parallel to the line
between the two pins.

I;ﬂl Align Vertical - Rotates the texture image to make its vertical axis parallel to the line
between the two pins.

@l Default - Restores the default texture tiling and mapping parameters, specified in the
Tools/Options/Texture Mapper dialog.

Painter
Contains commands for creating and saving pictures and textures as well as defining names
and categories.

@ | ﬂ | Mame II::IES Egtegu:urylliustu::m - I El

ﬁl New Picture - Creates a new picture.

@l New Texture - Creates a new texture.
El Save - Saves current picture or texture into the gallery.

Paint
Contains commands to select a drawing instrument, define its shape and select painting
operations.

17 2
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il Pencil - Selects a pen for drawing. The pen width can be defined using the Width and
Shape pane on the bottom of the Paint toolbar.

tylus - Selects a stylus for drawing. The stylus width can be defined using the Width an
*’fSI Sel lus for drawing. Th I idth be defined using the Width and
Shape pane on the bottom of the Paint toolbar.

gl Brush - Selects a brush for drawing. The brush width can be defined using the Width and
Shape pane on the bottom of the Paint toolbar.

@l Fill - Fills an area of connected points with a color.

ll Line - Draws a straight line. The line width can be defined using the Width and Shape
pane on the bottom of the Paint toolbar.

El Rectangle - Draws a rectangle. The line width can be defined using the Width and Shape
pane on the bottom of the Paint toolbar.

il Select Color - Pick up a color from any point on the picture or texture.

| Select - Selects a rectangular part of a picture or a texture.

gl Magnify - Magnifies a picture or a texture. The value of magnification can be defined
using the Width and Shape pane on the bottom of the Paint toolbar.

84



Reference

Set tool properties box (Paint toolbar)

You can set the properties of current painting/editing tool by clicking the items in this box.
The following options are available:

. Drawing shape - for Pencil, Stylus and Brush.

Line width - for Line and Rectangle.

210

J Selection mode - for Select tool.
1w -
[2n.]
G W
b | .
Zoom value - for the Magnify button.
Attributes

Contains commands to define a drawing attribute.

S i =
R e |
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* Transparency - Sets the desired transparency of the color.

§ Water - Sets the desired saturation of the color.
™ Tolerance - Sets the difference of the point colors when filling an area.

st =] B|Z|[= === 18] A2

Formatting
Contains commands to edit the Plain Text object in Object Editing mode.

= EIEI%I Alignment. Select the alignment click the corresponding button on the
Formatting toolbar.

+ . . . .

é‘J Text. Click this button to open the Format dialog box .To edit the text when the Format
dialog box is closed click the arrow to the right from the Text button and edit the text in a small
textbox which drops down. The text may contain several lines. Each line is located below the
previous line for the horizontal text orientation or to the right from the previous line for vertical
text orientation.

B Font style. To select font style click Bold or Italic buttons on the Formatting toolbar.
ISE'if :IT Font. Select a font from the list of available fonts.

Al . . . . . .
iy Orientation. Select the text lines orientation. Note, that the characters in the lines of the
Plain Text object always have vertical orientation.
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You can modify the material properties of faces using this toolbox.

Button bar. Contains three buttons:

fl Go to Face button. Moves the camerain the position, suitable
for viewing the face, which material you are editing.

EI Clear button. Removes the texture from the current material.
The face color becomes visible after this button was pressed.

EI Stop button. Stops the texture animation.

Material Preview window. A sample sphere with current material
properties is shown in this section of the Material bar.

Color control sliders section. Y ou can set the RGB value of the
material color in this section. The color is placed under the texture,
so it becomes visible only if the faceis not textured.

Color Circle. To define a custom color, click anywhere in thiscircle,
and then use the Luminosity dlider below to adjust the color's
attributes. If you define a color using the Red/Green/Blue scales, you
can look at this circle to make sure you defined the color as you
intended.

Luminosity control slider (at the left). You can set the possible
amounts of white and black in the color by dragging it up or down.

Transparency control slider. Drag this dlider to set the transparency
value of the current material.

Color palette section. Shows the basic colors available. To define a
custom color, Double-click the color cell to open Color dialog box.

Thisis the texture animation control of the Material bar. It is used to
create moving textures.

To animate the current texture:

1. Dragthe central green circlein the direction of the texture
motion.

2. Thered arm of the animation control is displayed. A longer
arm means faster motion. The direction of the texture
motion is defined with arm direction.

To stop animation:

¢ Click the Stop button on the toolbar at the top of the
Material bar.

86



Index

Index

3

D SCRIME ...ttt e e 6
{00 1o =7 o PP PPPPPPPPPRE 6

A

2o Lo SRR

adding and extracting shapes
toolbar button ..............c..c....
Align camera .......cccceeeevvcvinnenn..
Animate textures ............c..ue....
APPIY s
default texture..........vvvvvevnnes
face material............cccccennnnn.
shapes to scene
L1 LD (= PO PP PP PPPRPPPRT
FAN 1 =Tl g o 0 [ o To IR OUP PP

B

BACKOIOUNG ...ttt e oo e ettt e e e e e s ettt e e e e e e e e nntbeeeaaaeeaateeeaaaaaan
editing colors
OVEIVIEW ..oeeiiiiiieeeaee e

Basic layout........

BOX.....ooiiiiee

Building scene

duplicate.......cccveiieieiiiie e

navigate camera in Ruler window...........
navigate in Perspective View window
navigate in Plan window
rename

PICTUrE/MOVIE IOCALION ... ittt ettt e e e e e ettt e e e e e e e anbat e e e e e e e e aaeeeeeaaeeaannnnes
shape height
spacing between t00IDAr DULLONS..........ooi et e e e e e e e e nneee e e e e an

pick up a point color
L1 11 o TP
setting Specific COIOr @S traNSPAIENT ........... et e e e e e e e e s anaeeeaaeeaan
spread
Concept of ISB ...

Construct scene geometry
CoNtrol.......ccovveveeeieieieieieieienennns

87



Index

object into another hierarchy level
0bject INt0 ANONEr SCENE PIACE......coooi it e e e e e e e e e e e e e e e e an
ODJECES oviiii e
picture/movie............cccuvvveen..

Create ......ccocvvvveiiiiiiiiicei,
custom shapes
custom toolbar
NEW PICTUINE OF TEXEUIE ...ttt ettt ettt ettt ettt ettt ettt bttt e ettt e eab e e et e e ettt et e e et et e ket e be e e abeeneeesbeeennne s
new scene

objects
(03,170 To 1= SO PPEPRTRN

D

LS (00 0 11 =
L 1=V | o1 1T OSSR STPPRPP

(D U] o] [0 ) (o 10 1 =] - U OO PO PPPRR

put movie/picture..................

setting color.......ceeevviuvnnenn..
Fill an area with a color
Fit22, 41

AV e (oYY (o e o1 T=T ot SRS 41

window to scene
Frequently aSKed QUESTIONS ........ooiieiiiei ettt e e e e e e ettt et e e e e e e e e ennne e e e e aannbseeeeaaeeaan 3
FrOZEN PAIT OF SCENE ... ettt e e e e ettt e e e e e e e e bbb bt e e e e e e e e annteeeeeansbseeaaaaaaan 6

G

L= oYU PPPRRRN
(o] 11 7o) | [T To (2o 10T oL TP
fileS o
using galleries of ready items

Gel i,
assistance during your work

object INfo.....cccoviieie e
(14T PP P PP PPPPP PPN
H
Hardware and SYStemM FEQUITEIMENTS . .......iiiiiiiiciiiiiit e e e ee bttt e e e e e s e e e e e e e e e st e e e e aaeeseasantbaereaeeseasseaaaeeaans 2
[ 1= o PP PPRPP 2
How does ISB store the files Of QAllEriES ..........uviiiiiiie e a e 9

88



Index

ready SNAPE INTO SCENE ...ttt e e e e e ettt e e e e e e e e tae ettt e e e e e e e nsbaeeeeeaeaeaannaeeaaeeaannnnes
shape created 0N the flY ... et e e e et e e e e e e e ean
Installation
(151 R
features
frequently asked questions
hardware and system requirements
1015 e= 1| = LT o PP SOR
SIZING AN SCAlING IIMIES ....eeii ettt e e e e et e e e e e e s e st e eeeaansbaeeeaaaeean
technical support
(8o 1T 1Sy =1 T oo T PRSP

K

Keeping the VIrtual WOTIA CIEA ......... ..ot e e e e e s et e e e s s e e e e aeeaean

M

= a1 o101 F= L (o1 SRR EPRRR
object in the Perspective View window
shape in the Perspective View window

1\ F=T o] o1 o o PR UP T
one pin
two pins

Material .........ccoeeeiviiieiiiiiieene
default settings
OVEIVIEW Of MALEIIAl PrOPEITIES. .. uuiiiiiee e ittt et e e e e e e e e s e et e e e e e s seatbaa e e e aeeesearaaeaaeeeaan
[0 o [ oo (o ] SO OSSR TPPPRPR
setting texture
L] 0] (=T To [T ERP

move or copy toolbar button.......................
object into another hierarchy level
object into another scene place..............
EEXIUNE .
toolbar ............
Movie/picture
(o g F=Ta o [N (o Lo 1 1 o] o TSR

N

NAVIQALE CAMEIA .. .uvvviiiee ittt e e e e e e e e e e e e s satbaaaeeeas
in Perspective View window
in Plan Window ..........ccooceveiiiieneniieee,

ObjecCt....c.covvvciiiiiieiieen, 7,8,9, 36,37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54
change heightS USING RUIET .......... et e ettt e e e e e e s e e e e e e e e e e sneeeaaaeaaan

change size and position/orientation using Object manipulator
(o (=71 1] 0T TSR PRRRR

89



Index

(o0 17 oo o) VA=V aTo I o= ] £ TP
[0 =1 1= 11 o SRR TPPRRR
EAIL e

editing in the Object Editing mode
fit to window....
getinfo..........
(1] oJo] £ {1 o TR ERTR
manipulating in the Perspective View window
manipulator in the Perspective VIeW WINAOW. ...........ooiiiiiiiiiiiee e e e e e e e e
move and copy into another hierarchy level
move and copy into another scene place
MOoVINg and SNAPPING 10 TACE. ....uiiiiii ittt e e e s e e e e s e st a e e e e e e e s satbbaraeeeaaanees
placing into the scene............ccccveveeeeeiiiins
=T =10 o113 T PP PPPPRRRRS
rotating with the manipulators in the Perspective View window
SAVING CUMTENT....eeiiiiii ittt eee ettt e e e e et e e e e e st eeaa e e e sannneneeaeaeaas
scaling in the Perspective View window
SEIECT. ..
structured scene example ..........ccccveeeeeenn.

VRML primitive Cylinder

VRML PHIMILIVE SPREIE ...ttt e ettt e e e e e e e et e e e e e e e e e e nntbeeeeaeeeasnneeaaaeeaan
(O e T o T 44 F=To] o] 1T PSRRI
On-line pictrure or texture editing
OPEN i

(oIS (1T JESToT=] o TSSO RS PPRPR

P

[ 111 =] PR UTRPPERR
PlACING EXISHING TEXEUIE ...ttt ettt e e e e ettt et e e e e e e saebe et e e e e e aaansbseeeeaeaeeasneeeaaeeaannnnes
SEIBCT AIBA......eiiiiieeite ettt
show Painter window

ParallelGraphiCs WED SIt@ ......uuiiiiiiiiciiiiiii et e e e e e e e e e e st a e e e e e e s e aan s b e e e e s s atbbaaeaaeeeaan

PEISPECHIVE VIBW ....uiiiiiiiiiiic et e et e e e e e e sttt e et e e e e e st baeteaaeeessneaaeeeaan
manipulations with objects ...
PIACING SNAPES ...ttt oottt e e e e ettt et e e e e e e b ae et e e ee e e e anbbe et e e e e e enneeeeeaaeeaaannnes
re-sizing shapes

Phases of building virtual space

Pick up a point color

Picture ......ooooveiiiiceee
creating NeW..........cceeeuvvveen..
editing....coveeeiiiiiieie e
resizing
L= 1Y/ o T TP ERP

Pivot point

Place existing texture t0 Painter WINAOW .............ciiiiiiiiiiiiei e e e e e e e e e e e e s aeeaaeeeaan

Place texture to Texture MappPer WINOOW ............cooiiioiiiieiiiea e ee e e e e e e aaeeeeeaae e e e aantbeeeeaaaessaanneeeaeaaaan

Play sound ..........ccccovviieiieiiiiieeee e

plan .......ccoooviiie,
Publishing scene .............c.......
Put picture/movie to face

Q

(O TR TCE) 1o =TRSO PPRPR 3

90



Index

picture or texture
picture/movie............cccuvvveen..
Shape ..ccceeviiicieeee,
toolbar ............
RESOUICES ...
changing the reference iN the SCENE ...
MOodifying USEd IN the SCEMNE FESOUITES ......cceiiiiiiiiiiee e e ettt e e e e e ettt e e e e e e e e s eatbeeeeaaeeeaannnneeeeaaeannees
renaming
VIBWING T8 USE .. .uieiiiie ettt ettt e e e e e e ettt et e e e s e e bbbt e et e e e e e aasaatbeeeeaeeaasstbaaeeesnnsbbaaeeeaeenan
Restore initial texture
Rotate plan
Ruler window
CONLrOl ShAPE NEIGNT ...t e ettt e e e e s e e e e e e baeeeaeaeeaan
Ruler Window...........ccccceevnie
navigate Camera

current object
PICTUIE OF TEXEUIE ...t ee e e ettt ettt e e e e oo ettt e e e e e e e e e s ae et e e e e e e e e amntbeeeeeaeaesannnseneeeeannsbneeeaaeeaaannnes

apply shapes to scene
building tiPS ..vvveveeeeeeec e
changing the reference to the resources....
choose from gallery
[o7o]3 11T o TR

ToTo 1S3 (0Tt o T=T0] 1 41T YT
(o LT 1L 1= P PRSP PPPPRO
frozen part of scene example
modifying the resources
[o] o <] TS 1S3 1] o OSSR TPPRPP
preparing for publishing
renaming the resources

setting background...............
structured scene..................

upload to WWW ...................
Screen layout
1T o )| PPNt

default shape height.............

face color.......cooociieeiiiiniis

PICTUrE/MOVIE 0 FACE ....eeii ittt ettt e e e e ettt e e e e e e s nnbsb e e e e e e e e eeneeaaaeeaannnnes

shape position
size

oY o I 1T o1 v= Ui o] o O O P PSP PR TPV PPRPP

adding and extracting...........
apply to scene.........cccuueeeee.
change height..............c........
CONIOIING NEBIGNT ... et e e e e e e et e e e e e e s e sabeaeae e e s nsbaaneeeeeeaan

91



Index

CrEAte CUSTIOM SNAPES ... .eeiieiiiiiieeeitie e e et e e ettt e e et e e e st e e st e e e e antaeeesnseeeeanseeeeaanteeeeenaeeeeenseeanseeeennnees
include ready ShaPE INTO SCENE ... et e ettt e e e e e e et e e e e e e e e e nnbaee e e enneee
include shape created on the fly.................
placing in the Perspective View window
re-sizing in the Perspective View window
(= 0o (oY £ 10 L g T=T o | ) SRR PPRPR
set position
size
and orientation

(= 1101 (=T AT To [0 PP VPP PPPRPTPI
TEXTUIE MAPPEI WINTOW ....uvviiiiieeiiiiiiieet e e et eettte e e e e e e et e e e e e e e s estbaaeeeeeessastbereeeaeeesaassssbeeaaaeesassaseaeeeaann 58
Snap

T

I LGl 0] 4] oo T o | o PO PRRPPRNt
Technical support.....................
TEXE et
Plain Text object
TEXIUIE ..o
= a1 0 P 1] T SRR
F=T0] o] Y71 o To [ OSSR PPRPR
applying default ....................
changing transparency
copying modified tEXIUrES 10 fACES .......cciiiiiiiiie e e a e 62
creating cew
display TexXture MapPPEr WINGOW ..........ceui e ettt e e e e e e s aeeeeeeea e e e e s e ntbeeeeaaaaesaannnseeeeaaeeeaaanneeaaeaaan
(=0 1117 o TR SRR
MOVING ..ot ee et e e eea e
placing to theTexture Mapper window
FEMOVING. ... eviveiieee e e e ettt e e e e e eeae e
REeSIZING ...vvvveveeeiiiiiiiieeeee
restore Initial..........ccccoevvneen.
L= 1Y/ LT SRS UU ST PPRPP
L] 0] (=T To [T UU PRI
Tips for scene structure
QL0100 = U PP R
add or delete a toolbar DULION. ... e e et e e e e e
change the spacing between toolbar buttons
create a Custom tooIbar..........ccceveiiiiee i
delete a custom toolbar ....
disable or enable toolbar ..
display or hide toolbar ..........
move a toolbar............coccviiiiiiii
move or copy a toolbar button
rename a custom toolbar.............ccccceeeenes
TESIZE A LOOIDAN ... ittt eb e e e aaee s
Restore @ BUilt-In TOOIDAT ........ccoouiiiiiii et sbnee s
Transparent color
B o 10 {o] =1 aTo o] 11T TSRO PPRPPRNt
B[ [ [o o0 Lo i PP PURPPRN
BN o1 g ES g =T o] o Lo [P PRRPPRN

U
L0 1013 2= 1L o PP PPRPP 3

92



Index

L PSP PRR

Vv

RV 2T o RSP RPPRPPRNt
where the resource is used

VRML PrimitivVes .......coooiiieeiieiieeieiiieeeeeeeee
BOX oot

Cylinder..........
overview

w

A VT o] (=TT R PPPPPTPR
R T o R N 1] = SO PO PPPRPTPI
Working with menus.................

Working with the resources

picture or texture
b0 1011 010 ] o] - Lo [ RSO PRSPPI

93



	Welcome to Internet Space Builder
	What is ISB
	ISB Features
	ISB Quick Start Guide
	Getting Help
	Getting assistance
	Hardware and system requirements
	Installation
	Uninstalling ISB
	Technical support
	ParallelGraphics Web Site
	Frequently asked questions


	Getting Started
	Screen Layout
	Customizing layout
	Working with menus

	ISB Scene Building Concept
	Scene Building
	Example of stone statue
	Structured scene
	Keeping the virtual world clear
	Two modes of a scene construction
	Editing objects in the Object Editing mode

	Galleries of Already Built Items and Examples
	Galleries of ready items in ISB
	How does ISB store the files of galleries
	Phases of building the virtual space


	Basic Operations
	Creating, Opening and Saving 3D Scenes
	Create a new scene
	Open an existing scene
	Save a scene

	Controlling Camera
	Control cameras
	Navigate cameras in the Plan window
	Navigate active camera in the Perspective View window
	Navigate active camera in the Ruler window
	Align cameras
	Duplicate cameras
	Set active camera
	Rename cameras
	Delete cameras

	Constructing Scene
	Construct scene
	Include ready shapes into a scene
	Include shapes created on the fly
	Set shape position, size and orientation
	Apply shapes to scene

	Controlling Shape Heights
	Control shape heights
	Set shape’s default height
	Change shape heights
	Scroll the Ruler

	Creating New Shapes
	Create custom shapes

	Manipulating Plan
	Split the Plan window
	Turn the Grid on/off
	Rotate a plan
	Scroll a plan (pan the view port)
	Zoom of plan
	Fit a window to a scene
	Print a plan

	Using Shapes in the Perspective View Window
	Placing shapes in the Perspective View window
	Set shape position, size and orientation in the Perspective
	View window

	ISB Limits
	Scene Background and Landscape
	Scene background schemes: overview
	Setting the scene background and landscape scheme
	Editing Background colors

	Using Colors and Textures
	Setting the Face Material properties: overview
	Using face materials
	Applying default material to faces
	Material Bar
	Apply textures
	Setting face colors
	Spreading materials

	Using Pictures and Movies
	Set pictures/movies onto a face
	Specify movies play order
	Copy pictures/movies
	Change pictures/movies location
	Resize pictures/movies
	Delete pictures/movies


	Advanced Features
	Using Objects
	Use objects
	The Scene Tree
	Place Objects into the scene
	Working with the Geometry Clipboard Content
	Import objects

	Manipulating Objects
	Select objects
	Create objects
	Saving current object
	Deleting objects
	Renaming objects
	Get object info
	Move and copy objects into another place in scene
	Move and copy objects into another hierarchy level
	Fitting windows to objects

	Editing Objects
	Edit objects
	Changing size, position and orientation using Object Manipulator
	Changing object’s height using the Ruler
	Add and extract shapes
	Cut, copy, and paste objects and their parts

	Manipulating Objects in the Perspective View Window
	Manipulating objects in the Perspective View window
	Object manipulator controls in the Perspective View window
	Rotating the object directly in the Perspective View window
	Scaling the object directly in the Perspective View window
	Moving the object directly in the Perspective View window

	Using VRML Geometry Primitives
	VRML primitives: overview
	Box VRML primitive object
	Cylinder VRML primitive object
	Cone VRML primitive object
	Sphere VRML primitive object

	Using Plain Text Objects
	Using Plain Text objects

	Using 3D Fonts
	Multimedia Capabilities
	Attach sound
	Play sound
	Detach sound
	Link URLs
	Removing URLs

	Publishing Scene
	Preparing the scene for publishing
	Upload scene to the World Wide Web

	Texture Mapping
	Switching to the Texture Mapper window
	Placing textures into the Texture Mapper window
	Moving textures
	Mapping the texture relative to a pivot point
	Mapping textures relative to a line
	Restoring the initial texture
	Changing texture transparency
	Removing textures
	Animating textures
	Copy modified textures to faces

	Texture Painting
	Switching to the Painter window
	Creating a new picture or texture
	Placing pre-existing textures or pictures into the Painter window
	Draw a straight line or rectangle
	Draw a free-form line
	Fill an area with a color
	Using transparent colors
	Manipulating selected areas
	Pick up a point color
	Zoom In a picture or texture
	On-line picture or texture editing
	Resizing a picture or texture
	Saving a picture or texture

	Controlling Gallery Resources
	Moving, adding and deleting gallery resources

	Working with the Scene Resources and Resource References
	Working with the resources, used in the Scene
	Viewing where the selected resource is used in the scene
	Renaming resources
	Changing resource reference in the scene file

	Controlling the navigation type
	Setting ISB options
	General
	The HTML options dialog box

	Plan
	Camera
	Galleries
	Texture Mapper

	Keyboard Navigation dialog box
	Customizing Toolbars
	Display or hide toolbar
	Disable or enable custom toolbar
	Move a toolbar
	Resize a toolbar
	Restore a built-in toolbar
	Create a custom toolbar
	Delete a custom toolbar
	Rename a custom toolbar
	Add or delete a toolbar button
	Change the spacing between toolbar button
	Move or copy a toolbar button


	Troubleshooting
	Reference
	Main Menu
	Toolbars

	Index

